summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mbx8xx/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 13:11:22 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 13:11:22 +0000
commitdb0b36999d611a0e4b555cde9dc3210e41d5e1bc (patch)
tree39d6ec4337bfe101d0af32632b11ea92993556ef /c/src/lib/libbsp/powerpc/mbx8xx/Makefile.am
parent2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-db0b36999d611a0e4b555cde9dc3210e41d5e1bc.tar.bz2
2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. Reflect changes to bsp.am. * include/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/mbx8xx/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/mbx8xx/Makefile.am35
1 files changed, 31 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/powerpc/mbx8xx/Makefile.am b/c/src/lib/libbsp/powerpc/mbx8xx/Makefile.am
index f974df1642..a91cf18c7e 100644
--- a/c/src/lib/libbsp/powerpc/mbx8xx/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/mbx8xx/Makefile.am
@@ -5,13 +5,40 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = include clock console irq network ide startup vectors \
- @exceptions@ wrapup
+# from the individual .rel files built in other directories
+SUBDIRS = . clock console irq network ide startup vectors @exceptions@ \
+ wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = README bsp_specs times
+include_bspdir = $(includedir)/bsp
+
+include_HEADERS += include/coverhd.h
+include_bsp_HEADERS = include/mbx.h include/commproc.h include/8xx_immap.h
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = times
+
+$(PROJECT_INCLUDE)/bsp:
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/bsp
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp
+
+$(PROJECT_INCLUDE)/bsp/mbx.h: include/mbx.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/mbx.h
+
+$(PROJECT_INCLUDE)/bsp/commproc.h: include/commproc.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/commproc.h
+
+$(PROJECT_INCLUDE)/bsp/8xx_immap.h: include/8xx_immap.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/8xx_immap.h
+
+$(PROJECT_INCLUDE)/coverhd.h: include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am