summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/gen83xx/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2010-11-12 14:16:57 +0000
committerSebastian Huber <sebastian.huber@embedded-brains.de>2010-11-12 14:16:57 +0000
commit8a54204379574c12af94a9491a91cf59a5857e22 (patch)
tree8000c0ad4c8734fc33326e0d37abd5c12f10d80f /c/src/lib/libbsp/powerpc/gen83xx/configure.ac
parent2010-11-12 Sebastian Huber <sebastian.huber@embedded-brains.de> (diff)
downloadrtems-8a54204379574c12af94a9491a91cf59a5857e22.tar.bz2
2010-11-12 Sebastian Huber <sebastian.huber@embedded-brains.de>
* console/console.h, console/console.c, console/config.c, console/ns16550cfg.c: Removed files. * console/console-config.c: New file. * Makefile.am: Reflect changes above. * configure.ac: New BSP options. * include/bsp.h: Use new BSP options. * network/network.c: Avoid memory leak. * startup/bspstart.c: Initialize console port table. * spi/spi_init.c: Update for SD card API changes.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/gen83xx/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/gen83xx/configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/gen83xx/configure.ac b/c/src/lib/libbsp/powerpc/gen83xx/configure.ac
index 1671c45fe8..2552ec03cf 100644
--- a/c/src/lib/libbsp/powerpc/gen83xx/configure.ac
+++ b/c/src/lib/libbsp/powerpc/gen83xx/configure.ac
@@ -43,6 +43,24 @@ RTEMS_BSPOPTS_SET([MPC8349],[hsc_cm01],[1])
RTEMS_BSPOPTS_HELP([MPC8349],
[If defined, use custom settings for the MPC8349 libcpu family.])
+RTEMS_BSPOPTS_SET([BSP_CONSOLE_BAUD],[mpc8313erdb],[115200])
+RTEMS_BSPOPTS_SET([BSP_CONSOLE_BAUD],[*],[9600])
+RTEMS_BSPOPTS_HELP([BSP_CONSOLE_BAUD],[Default baud for console and other serial devices.])
+
+RTEMS_BSPOPTS_SET([BSP_USE_UART_INTERRUPTS],[mpc8313erdb],[1])
+RTEMS_BSPOPTS_HELP([BSP_USE_UART_INTERRUPTS],[enable usage of interrupts for the UART modules])
+
+RTEMS_BSPOPTS_SET([BSP_USE_UART2],[mpc8313erdb],[1])
+RTEMS_BSPOPTS_SET([BSP_USE_UART2],[mpc8349eamds],[1])
+RTEMS_BSPOPTS_SET([BSP_USE_UART2],[hsc_cm01],[1])
+RTEMS_BSPOPTS_HELP([BSP_USE_UART2],[If defined, enables UART2.])
+
+RTEMS_BSPOPTS_SET([HAS_UBOOT],[mpc8313erdb],[1])
+RTEMS_BSPOPTS_HELP([HAS_UBOOT],[If defined, enables U-Boot support.])
+
+RTEMS_BSPOPTS_SET([PPC_USE_DATA_CACHE],[*],[1])
+RTEMS_BSPOPTS_HELP([PPC_USE_DATA_CACHE], [If defined, then the PowerPC specific
+ code in RTEMS will use data cache instructions to optimize the context switch code.])
RTEMS_CHECK_NETWORKING
AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")