summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/gen83xx/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2010-12-30 13:16:41 +0000
committerSebastian Huber <sebastian.huber@embedded-brains.de>2010-12-30 13:16:41 +0000
commitce0922e685e270f0c2c7744430fd6ddcc09c1c43 (patch)
treee490a71b87193c642c4a7a51b85df150dd18e50f /c/src/lib/libbsp/powerpc/gen83xx/Makefile.am
parent2010-12-30 Sebastian Huber <sebastian.huber@embedded-brains.de> (diff)
downloadrtems-ce0922e685e270f0c2c7744430fd6ddcc09c1c43.tar.bz2
2010-12-30 Sebastian Huber <sebastian.huber@embedded-brains.de>
* include/u-boot.h: Removed file. * include/u-boot-config.h, include/tsec-config.h: New files. * include/bsp.h, start/start.S, startup/bspstart.c: Use new U-Boot support. * network/network.c: Update for API changes. * Makefile.am, preinstall.am: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/gen83xx/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/gen83xx/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/powerpc/gen83xx/Makefile.am b/c/src/lib/libbsp/powerpc/gen83xx/Makefile.am
index cbb6e265bf..6a5bb11124 100644
--- a/c/src/lib/libbsp/powerpc/gen83xx/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/gen83xx/Makefile.am
@@ -57,7 +57,7 @@ libbsp_a_SOURCES += ../../shared/bsplibc.c \
../../shared/bspclean.c \
startup/bspreset.c \
../../shared/bspgetworkarea.c \
- startup/uboot_support.c \
+ ../../shared/src/bsp-uboot-board-info.c \
../shared/uboot_getenv.c
# clock
@@ -66,9 +66,12 @@ libbsp_a_SOURCES += ../shared/clock/clock.c
include_bsp_HEADERS = include/irq.h \
../../shared/include/irq-generic.h \
../../shared/include/irq-info.h \
+ ../../shared/include/u-boot.h \
+ ../shared/include/u-boot-board-info.h \
+ ../shared/include/tictac.h \
include/hwreg_vals.h \
- ../shared/include/u-boot.h \
- ../shared/include/tictac.h
+ include/tsec-config.h \
+ include/u-boot-config.h
# irq
libbsp_a_SOURCES += irq/irq.c \