summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-12-17 10:53:28 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-12-17 10:53:28 +0000
commit7b110d2005bf8527b08279d08254a09e02e31483 (patch)
treed952ee726d4e09d4bc2ad5c166ea6f018497f1f5 /c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am
parent2002-12-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-7b110d2005bf8527b08279d08254a09e02e31483.tar.bz2
2002-12-17 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* canbus/Makefile.am: Don't include @RTEMS_BSP@.cfg. * clock/Makefile.am: Don't include @RTEMS_BSP@.cfg. * console/Makefile.am: Don't include @RTEMS_BSP@.cfg. * irq/Makefile.am: Don't include @RTEMS_BSP@.cfg. Remove SORDID_HACK. Eliminate *_O_FILES. * network/Makefile.am: Don't include @RTEMS_BSP@.cfg. * start/Makefile.am: Don't include @RTEMS_BSP@.cfg. * startup/Makefile.am: Don't include @RTEMS_BSP@.cfg. * vectors/Makefile.am: Don't include @RTEMS_BSP@.cfg.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am13
1 files changed, 3 insertions, 10 deletions
diff --git a/c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am b/c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am
index 1e7076c84b..02369bb88c 100644
--- a/c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am
@@ -6,23 +6,16 @@
include_bspdir = $(includedir)/bsp
C_FILES = irq.c irq_init.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
+OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
include_bsp_HEADERS = irq.h
S_FILES = irq_asm.S
-S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
+OBJS += $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
-OBJS = $(C_O_FILES) $(S_O_FILES)
-
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../../../../../../automake/compile.am
include $(top_srcdir)/../../../../../../automake/lib.am
-## FIXME: WTF is this?
-SORDID_HACK:
- rm -f $(PROJECT_INCLUDE)/bsp/irq.h
-
$(PROJECT_INCLUDE)/bsp:
$(mkinstalldirs) $@
@@ -41,7 +34,7 @@ $(PGM): $(OBJS)
# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
-all-local: SORDID_HACK $(PREINSTALL_FILES) $(ARCH) $(OBJS) $(PGM)
+all-local: $(PREINSTALL_FILES) $(ARCH) $(OBJS) $(PGM)
EXTRA_DIST = irq.c irq_asm.S irq_init.c