summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 15:59:23 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 15:59:23 +0000
commit5466140831377302760358353a2fc7e84ceb234d (patch)
tree80c5a32b9a2ca87328e687b3da1d06a020b8417c /c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am
parent2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-5466140831377302760358353a2fc7e84ceb234d.tar.bz2
2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in canbus/Makefile.am, clock/Makefile.am, console/Makefile.am, irq/Makefile.am, network/Makefile.am, startup/Makefile.am, vectors/Makefile.am. Use automake compilation rules. * canbus/Makefile.am, clock/Makefile.am, console/Makefile.am, irq/Makefile.am, network/Makefile.am, startup/Makefile.am, vectors/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am41
1 files changed, 0 insertions, 41 deletions
diff --git a/c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am b/c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am
deleted file mode 100644
index 1ee123056b..0000000000
--- a/c/src/lib/libbsp/powerpc/eth_comm/irq/Makefile.am
+++ /dev/null
@@ -1,41 +0,0 @@
-##
-## $Id$
-##
-
-include_bspdir = $(includedir)/bsp
-
-C_FILES = irq.c irq_init.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-include_bsp_HEADERS = irq.h
-
-S_FILES = irq_asm.S
-OBJS += $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-noinst_DATA = $(OBJS)
-
-# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
-
-all-local: $(PREINSTALL_FILES)
-
-EXTRA_DIST = irq.c irq_asm.S irq_init.c
-
-PREINSTALL_DIRS =
-PREINSTALL_FILES =
-
-$(PROJECT_INCLUDE)/bsp/$(dirstamp):
- @$(mkdir_p) $(PROJECT_INCLUDE)/bsp
- @: > $(PROJECT_INCLUDE)/bsp/$(dirstamp)
-PREINSTALL_DIRS += $(PROJECT_INCLUDE)/bsp/$(dirstamp)
-
-$(PROJECT_INCLUDE)/bsp/irq.h: irq.h $(PROJECT_INCLUDE)/bsp/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/bsp/irq.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/irq.h
-
-CLEANFILES = $(PREINSTALL_FILES)
-DISTCLEANFILES = $(PREINSTALL_DIRS)
-
-include $(top_srcdir)/../../../../automake/local.am