summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/eth_comm/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-11-20 18:51:46 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-11-20 18:51:46 +0000
commit73d6cdc54836bd454ef8fb33046254a18f1eb845 (patch)
tree32a181f1871ade705cb5f6802faf5ad9a47cf62e /c/src/lib/libbsp/powerpc/eth_comm/configure.ac
parent2001-11-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-73d6cdc54836bd454ef8fb33046254a18f1eb845.tar.bz2
2001-11-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add @exceptions@ to SUBDIRS. * configure.ac: Add RTEMS_BSPOPTS_*(UARTS_IO_MODE), RTEMS_PPC_EXCEPTIONS([new]). * include/Makefile.am: Convert PREINSTALL_FILES to TMPINSTALL_FILES, include force-preinstall.am. * irq/Makefile.am: remove irq.h from EXTRA_DIST. * wrapup/Makefile.am: Apply @exceptions@.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/eth_comm/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/eth_comm/configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/eth_comm/configure.ac b/c/src/lib/libbsp/powerpc/eth_comm/configure.ac
index fc7f34910a..86ad873962 100644
--- a/c/src/lib/libbsp/powerpc/eth_comm/configure.ac
+++ b/c/src/lib/libbsp/powerpc/eth_comm/configure.ac
@@ -24,6 +24,21 @@ RTEMS_CANONICAL_HOST
AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
+# FIXME: Explanation cloned from mbx8xx
+RTEMS_BSPOPTS_SET([UARTS_IO_MODE],[*],[0])
+RTEMS_BSPOPTS_HELP([UARTS_IO_MODE],
+[(BSP--console driver)
+ Define to 0 or 1 if you want polled I/O performed by RTEMS.
+ Define to 1 if you want interrupt-driven performed by RTEMS.
+ Define to 2 if you want polled I/O performed by EPPCBug.
+ There is no provision to have a mix of interrupt-driven and polled I/O
+ ports, except that the printk port may use a different mode from the
+ other ports. If this is done, do not open the printk port from an RTEMS
+ application. With EPPCBug 1.1, if mode 2 is selected, CONSOLE_MINOR
+ must be set to SMC1_MINOR. This is a deficiency of the firmware: it
+ does not perform serial I/O on any port other than its default debug
+ port, which must be SMC1.])
+
AM_CONFIG_HEADER(include/bspopts.h)
RTEMS_PROJECT_ROOT
@@ -39,4 +54,7 @@ start/Makefile
startup/Makefile
vectors/Makefile
wrapup/Makefile])
+
+RTEMS_PPC_EXCEPTIONS([new])
+
AC_OUTPUT