summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/ep1a/configure.ac
diff options
context:
space:
mode:
authorTill Straumann <strauman@slac.stanford.edu>2011-05-18 05:26:53 +0000
committerTill Straumann <strauman@slac.stanford.edu>2011-05-18 05:26:53 +0000
commit4f599ed99fc0aa37bc4d100cf787880c1e1bb97a (patch)
tree56fa22232321006e3aa761e38495a786d0f3632d /c/src/lib/libbsp/powerpc/ep1a/configure.ac
parent2011-05-16 Yaakov Selkowitz <yselkowitz@users.sourceforge.net> (diff)
downloadrtems-4f599ed99fc0aa37bc4d100cf787880c1e1bb97a.tar.bz2
2011-05-18 Till Straumann <strauman@slac.stanford.edu>
PR1797/bsps: Applied cleaned-up version of Kate's patch. CONFIGURE_MALLOC_BSP_SUPPORTS_SBRK is now a 'bspopts.h' setting and as such configurable.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/ep1a/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/ep1a/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/ep1a/configure.ac b/c/src/lib/libbsp/powerpc/ep1a/configure.ac
index 0ffce65384..a5a006ded3 100644
--- a/c/src/lib/libbsp/powerpc/ep1a/configure.ac
+++ b/c/src/lib/libbsp/powerpc/ep1a/configure.ac
@@ -33,6 +33,16 @@ RTEMS_BSPOPTS_SET([CONSOLE_USE_INTERRUPTS],[*],[0])
RTEMS_BSPOPTS_HELP([CONSOLE_USE_INTERRUPTS],
[whether using console interrupts])
+RTEMS_BSPOPTS_SET([CONFIGURE_MALLOC_BSP_SUPPORTS_SBRK], [*], [1])
+RTEMS_BSPOPTS_HELP([CONFIGURE_MALLOC_BSP_SUPPORTS_SBRK],
+[If defined then the BSP may reduce the available memory size
+initially. This can be useful for debugging (reduce the core
+size) or dynamic loading (std gcc text offsets/jumps are < +/-32M).
+Note that the policy can still be defined by the application
+(see sbrk.c, BSP_sbrk_policy). By undefining
+CONFIGURE_MALLOC_BSP_SUPPORTS_SBRK this feature is removed
+and a little memory is saved.])
+
RTEMS_CHECK_NETWORKING
AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")