summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/dmv177/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-09 14:52:49 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-09 14:52:49 +0000
commit2a64a03531497193017f17d2e6cca39e2640da2e (patch)
treea75b4773d988e67ed286ff085788d28647e6baf0 /c/src/lib/libbsp/powerpc/dmv177/startup/Makefile.am
parent2003-12-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-2a64a03531497193017f17d2e6cca39e2640da2e.tar.bz2
2003-12-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* start/Makefile.am: Misc cleanups and fixes. * startup/Makefile.am: Misc cleanups and fixes. * wrapup/Makefile.am: Misc cleanups and fixes.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/dmv177/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/dmv177/startup/Makefile.am15
1 files changed, 6 insertions, 9 deletions
diff --git a/c/src/lib/libbsp/powerpc/dmv177/startup/Makefile.am b/c/src/lib/libbsp/powerpc/dmv177/startup/Makefile.am
index 48b4c3d073..08f9da6577 100644
--- a/c/src/lib/libbsp/powerpc/dmv177/startup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/dmv177/startup/Makefile.am
@@ -22,17 +22,14 @@ include $(top_srcdir)/../../../../automake/lib.am
$(PGM): $(OBJS)
$(make-rel)
-bsplib_DATA = linkcmds
+project_lib_DATA = linkcmds
-$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds
-
-all-local: $(OBJS) $(PGM) $(TMPINSTALL_FILES)
-
-.PRECIOUS: $(PGM)
+all-local: $(PGM) $(TMPINSTALL_FILES)
EXTRA_DIST = bspclean.c bspstart.c genpvec.c linkcmds setvec.c vmeintr.c
+${PROJECT_RELEASE}/lib/linkcmds: linkcmds ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds
+
include $(top_srcdir)/../../../../automake/local.am