summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/dmv177/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-05-24 20:03:27 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-05-24 20:03:27 +0000
commitb1a2ae922a6a00f48a18303c97f1cb59f5527e78 (patch)
tree65cbfce2485230df34b1e1c778b57b5b5ebf1135 /c/src/lib/libbsp/powerpc/dmv177/configure.in
parent2001-05-22 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-b1a2ae922a6a00f48a18303c97f1cb59f5527e78.tar.bz2
2001-05-22 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.in: Add bspopts.h, AC_DEFINE CONSOLE_USE_INTERRUPTS, CONSOLE_USE_POLLED, HAS_RTC. * include/.cvsignore: Add bspopts.h*, stamp-h*, coverhd.h, tod.h. * include/Makefile.am: Use *_HEADERS instead of *H_FILES, New treatment of tod.h, coverhd.h. * include/bsp.h: Add include bspopts.h.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/dmv177/configure.in')
-rw-r--r--c/src/lib/libbsp/powerpc/dmv177/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/dmv177/configure.in b/c/src/lib/libbsp/powerpc/dmv177/configure.in
index 7e98c7038f..ec37042556 100644
--- a/c/src/lib/libbsp/powerpc/dmv177/configure.in
+++ b/c/src/lib/libbsp/powerpc/dmv177/configure.in
@@ -23,6 +23,25 @@ RTEMS_CANONICAL_HOST
AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
+## bsp-specific options
+CONSOLE_USE_INTERRUPTS=${CONSOLE_USE_INTERRUPTS-0}
+AC_DEFINE_UNQUOTED([CONSOLE_USE_INTERRUPTS],
+ [$CONSOLE_USE_INTERRUPTS],
+ [whether using console interrupts])
+
+## FIXME: this is redundant to CONSOLE_USE_INTERRUPTS
+CONSOLE_USE_POLLED="!CONSOLE_USE_INTERRUPTS"
+AC_DEFINE_UNQUOTED([CONSOLE_USE_POLLED],
+ [$CONSOLE_USE_POLLED],
+ [whether using polled console])
+
+## FIXME: This is not used anywhere
+HAS_RTC=${HAS_RTC-yes}
+AC_DEFINE_UNQUOTED([HAS_RTC],
+ [$HAS_RTC],
+ [whether this BSP has an RTC])
+
+AM_CONFIG_HEADER(include/bspopts.h)
RTEMS_PROJECT_ROOT
# Explicitly list all Makefiles here