summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/dmv177/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-02-12 03:31:07 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-02-12 03:31:07 +0000
commit5133bd66b7719450ad360d0e2a55a6d863a51818 (patch)
tree8991da9ed8b6a8880f2e0d5311f30b0107222ae0 /c/src/lib/libbsp/powerpc/dmv177/Makefile.am
parent2005-02-11 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-5133bd66b7719450ad360d0e2a55a6d863a51818.tar.bz2
2005-02-11 Ralf Corsepius <ralf.corsepius@rtems.org>
* Makefile.am: Merge-in wrapup/Makefile.am. * wrapup/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/dmv177/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/dmv177/Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/c/src/lib/libbsp/powerpc/dmv177/Makefile.am b/c/src/lib/libbsp/powerpc/dmv177/Makefile.am
index 0acbd0e812..e179e0f1c4 100644
--- a/c/src/lib/libbsp/powerpc/dmv177/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/dmv177/Makefile.am
@@ -4,10 +4,6 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
-# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = . @exceptions@ wrapup
-
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../bsp.am
@@ -74,6 +70,18 @@ sonic_rel_CPPFLAGS = $(AM_CPPFLAGS) $(sonic_CPPFLAGS)
sonic_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
+noinst_LIBRARIES = libbsp.a
+CLEANFILES = libbsp.a
+libbsp_a_SOURCES =
+
+libbsp_a_LIBADD = startup.rel clock.rel console.rel scv64.rel timer.rel \
+ tod.rel
+if HAS_NETWORKING
+libbsp_a_LIBADD += sonic.rel
+endif
+libbsp_a_LIBADD += ../../../libcpu/@RTEMS_CPU@/@exceptions@/rtems-cpu.rel \
+ ../../../libcpu/@RTEMS_CPU@/shared/cache.rel
+
all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
EXTRA_DIST += QUIRKS README.net STATUS cable.doc times
@@ -128,7 +136,7 @@ $(PROJECT_LIB)/linkcmds: startup/linkcmds $(PROJECT_LIB)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds
PREINSTALL_FILES += $(PROJECT_LIB)/linkcmds
-CLEANFILES = $(PREINSTALL_FILES)
+CLEANFILES += $(PREINSTALL_FILES)
DISTCLEANFILES += $(PREINSTALL_DIRS)
CLEANFILES += $(TMPINSTALL_FILES)