summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/or32/orp/startup/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-08-06 20:24:47 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-08-06 20:24:47 +0000
commitab678108354c8cd1969ccc5fdfdb963ce16ca4d6 (patch)
treedf15e7085fe2aa88d9baba54834ff99ae692b9cc /c/src/lib/libbsp/or32/orp/startup/Makefile.am
parent2002-08-06 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-ab678108354c8cd1969ccc5fdfdb963ce16ca4d6.tar.bz2
2002-08-06 Joel Sherrill <joel@OARcorp.com>
* bsp_specs, configure.ac, startup/bspstart.c: Update and fix minor things so this BSP compiles and almost completely links. * startup/Makefile.am: New file.
Diffstat (limited to 'c/src/lib/libbsp/or32/orp/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/or32/orp/startup/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/or32/orp/startup/Makefile.am b/c/src/lib/libbsp/or32/orp/startup/Makefile.am
new file mode 100644
index 0000000000..3f10bc8f6d
--- /dev/null
+++ b/c/src/lib/libbsp/or32/orp/startup/Makefile.am
@@ -0,0 +1,44 @@
+##
+## $Id$
+##
+
+
+VPATH = @srcdir@:@srcdir@/../../../shared
+
+PGM = $(ARCH)/startup.rel
+
+C_FILES = bsplibc.c bsppost.c bspstart.c bootcard.c main.c sbrk.c \
+ gnatinstallhandler.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+S_FILES =
+S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES) $(S_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(OBJS)
+ $(make-rel)
+
+bsplib_DATA = linkcmds
+
+$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
+ $(INSTALL_DATA) $< $@
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds
+
+all-local: $(ARCH) $(OBJS) $(PGM) $(TMPINSTALL_FILES)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = bspclean.c bspstart.c exit.c linkcmds setvec.c
+
+include $(top_srcdir)/../../../../../../automake/local.am