summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/or32/orp/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 09:56:23 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 09:56:23 +0000
commit82a7f58038fb9d7eb897241bd2d8ea6ecac5a05b (patch)
tree9e2da6d20d04f6e04236adcd95f3534d2a8c6636 /c/src/lib/libbsp/or32/orp/Makefile.am
parent2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-82a7f58038fb9d7eb897241bd2d8ea6ecac5a05b.tar.bz2
2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. Reflect changes to bsp.am. * include/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/or32/orp/Makefile.am')
-rw-r--r--c/src/lib/libbsp/or32/orp/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/or32/orp/Makefile.am b/c/src/lib/libbsp/or32/orp/Makefile.am
index 1e26a4ca29..e4055306e1 100644
--- a/c/src/lib/libbsp/or32/orp/Makefile.am
+++ b/c/src/lib/libbsp/or32/orp/Makefile.am
@@ -5,12 +5,18 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = . include clock console startup timer start wrapup
+# from the individual .rel files built in other directories
+SUBDIRS = . clock console startup timer start wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs
+include_HEADERS += include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+$(PROJECT_INCLUDE)/coverhd.h: include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am