summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-02-02 04:43:36 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-02-02 04:43:36 +0000
commited4f16b04500fd6874b3be2dd1617e21d7b66e78 (patch)
tree3c73f047a695e050306f08783fface74171c28ba /c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am
parent2004-02-02 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-ed4f16b04500fd6874b3be2dd1617e21d7b66e78.tar.bz2
2004-02-02 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in clock/Makefile.am, console/Makefile.am, shmsupp/Makefile.am, startup/Makefile.am, timer/Makefile.am, wrapup/Makefile.am. Use automake compilation rules. * clock/Makefile.am, console/Makefile.am, shmsupp/Makefile.am, startup/Makefile.am, timer/Makefile.am, wrapup/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am21
1 files changed, 0 insertions, 21 deletions
diff --git a/c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am b/c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am
deleted file mode 100644
index 607a9af416..0000000000
--- a/c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am
+++ /dev/null
@@ -1,21 +0,0 @@
-##
-## $Id$
-##
-
-if HAS_MP
-BSP_MP_O_FILES = shmsupp
-endif
-BSP_FILES = startup clock console timer $(BSP_MP_O_FILES)
-
-# bummer; have to use $foreach since % pattern subst rules only replace 1x
-OBJS = $(foreach piece, $(BSP_FILES), ../$(piece)/$(ARCH)/*.$(OBJEXT))
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-$(ARCH)/libbsp.a: $(OBJS)
- $(make-library)
-
-noinst_DATA = $(ARCH)/libbsp.a
-
-include $(top_srcdir)/../../../../automake/local.am