summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-08-11 06:58:28 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-08-11 06:58:28 +0000
commitc61c0977bee7a0fdb6c9dc7b3b17eef049d0ad35 (patch)
tree5a80e2f881192f0ea127d0eaecf1f5dc9f2ea3e1 /c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am
parent2002-08-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-c61c0977bee7a0fdb6c9dc7b3b17eef049d0ad35.tar.bz2
2002-08-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* clock/Makefile.am: Use .$(OBJEXT) instead of .o. * console/Makefile.am: Use .$(OBJEXT) instead of .o. * shmsupp/Makefile.am: Use .$(OBJEXT) instead of .o. * startup/Makefile.am: Use .$(OBJEXT) instead of .o. * timer/Makefile.am: Use .$(OBJEXT) instead of .o. * wrapup/Makefile.am: Use .$(OBJEXT) instead of .o.
Diffstat (limited to 'c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am b/c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am
index d6bfd51432..96788b2463 100644
--- a/c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/no_cpu/no_bsp/wrapup/Makefile.am
@@ -13,7 +13,7 @@ endif
BSP_FILES = startup clock console timer $(BSP_MP_O_FILES)
# bummer; have to use $foreach since % pattern subst rules only replace 1x
-OBJS = $(foreach piece, $(BSP_FILES), $(wildcard ../$(piece)/$(ARCH)/*.o)) \
+OBJS = $(foreach piece, $(BSP_FILES), $(wildcard ../$(piece)/$(ARCH)/*.$(OBJEXT))) \
$(foreach piece, $(GENERIC_FILES), ../../../$(piece)/$(ARCH)/$(piece).rel)
LIB = $(ARCH)/libbsp.a