summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/no_cpu/no_bsp/console/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
commit4e36a2f133c68aaf637e166385eff1a05b59f38e (patch)
tree47520e4fbb8b685c25ae2909cf2a12287be4268b /c/src/lib/libbsp/no_cpu/no_bsp/console/Makefile.am
parentPatch rtems-rc-20000118-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4e36a2f133c68aaf637e166385eff1a05b59f38e.tar.bz2
Patches rtems-rc-20000118-3.diff and rtems-rc-20000118-4.diff from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> that contain: * Modifications, (minor) corrections, cleanups to most existing Makefile.ams * Adds automake support to all remaining BSPs which have not yet been converted to automake. * Makefile.am for all remaining wrapup/Makefile.ams
Diffstat (limited to 'c/src/lib/libbsp/no_cpu/no_bsp/console/Makefile.am')
-rw-r--r--c/src/lib/libbsp/no_cpu/no_bsp/console/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/c/src/lib/libbsp/no_cpu/no_bsp/console/Makefile.am b/c/src/lib/libbsp/no_cpu/no_bsp/console/Makefile.am
index 124c211820..82b58ef82e 100644
--- a/c/src/lib/libbsp/no_cpu/no_bsp/console/Makefile.am
+++ b/c/src/lib/libbsp/no_cpu/no_bsp/console/Makefile.am
@@ -4,11 +4,10 @@
AUTOMAKE_OPTIONS = foreign 1.4
-PGM = ${ARCH}/console.rel
+PGM = $(ARCH)/console.rel
-## C source names
C_FILES = console.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
@@ -19,13 +18,15 @@ include $(top_srcdir)/../../../../../../automake/lib.am
# (OPTIONAL) Add local stuff here using +=
#
-$(PGM): ${OBJS}
+$(PGM): $(OBJS)
$(make-rel)
-all-local: ${ARCH} $(PGM)
-
# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
-EXTRA_DIST = $(C_FILES)
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = console.c
include $(top_srcdir)/../../../../../../automake/local.am