summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/mips/p4000/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-11 05:41:58 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-11 05:41:58 +0000
commite725be085804c1c11f7b6bbcc763bc4fe164465e (patch)
treef60bb7bad979940585a7c9154f1979b428560110 /c/src/lib/libbsp/mips/p4000/startup/Makefile.am
parent2003-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e725be085804c1c11f7b6bbcc763bc4fe164465e.tar.bz2
2003-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* start/Makefile.am: Misc cleanups and fixes. * startup/Makefile.am: Misc cleanups and fixes. * wrapup/Makefile.am: Misc cleanups and fixes.
Diffstat (limited to 'c/src/lib/libbsp/mips/p4000/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/mips/p4000/startup/Makefile.am22
1 files changed, 10 insertions, 12 deletions
diff --git a/c/src/lib/libbsp/mips/p4000/startup/Makefile.am b/c/src/lib/libbsp/mips/p4000/startup/Makefile.am
index 470514192e..706dddc406 100644
--- a/c/src/lib/libbsp/mips/p4000/startup/Makefile.am
+++ b/c/src/lib/libbsp/mips/p4000/startup/Makefile.am
@@ -25,23 +25,21 @@ include $(top_srcdir)/../../../../automake/lib.am
$(PGM): $(OBJS)
$(make-rel)
-bsplib_DATA = linkcmds ghlinkcmds
-
-$(PROJECT_RELEASE)/lib/ghlinkcmds: ghlinkcmds
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
- $(INSTALL_DATA) $< $@
+project_lib_DATA = linkcmds ghlinkcmds
# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/ghlinkcmds \
- $(PROJECT_RELEASE)/lib/linkcmds
-
-all-local: $(OBJS) $(PGM) $(TMPINSTALL_FILES)
-.PRECIOUS: $(PGM)
+all-local: $(PGM) $(TMPINSTALL_FILES)
EXTRA_DIST = bspclean.c bspstart.c ghlinkcmds idtmem.S idttlb.S inittlb.c \
linkcmds setvec.c
+${PROJECT_RELEASE}/lib/linkcmds: linkcmds ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds
+
+${PROJECT_RELEASE}/lib/ghlinkcmds: ghlinkcmds ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/ghlinkcmds
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/ghlinkcmds
+
include $(top_srcdir)/../../../../automake/local.am