summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/mips/p4000/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-02-02 03:55:55 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-02-02 03:55:55 +0000
commitc6070c42052cc11989d5133cdd29f0c42fabfd59 (patch)
tree2797fe79b66f040a2bae434a38f9542c3d830cbd /c/src/lib/libbsp/mips/p4000/startup/Makefile.am
parent2004-02-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-c6070c42052cc11989d5133cdd29f0c42fabfd59.tar.bz2
2004-02-02 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in console/Makefile.am, liblnk/Makefile.am, start/Makefile.am, startup/Makefile.am, wrapup/Makefile.am. Use automake compilation rules. * console/Makefile.am, liblnk/Makefile.am, start/Makefile.am, startup/Makefile.am, wrapup/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/mips/p4000/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/mips/p4000/startup/Makefile.am54
1 files changed, 0 insertions, 54 deletions
diff --git a/c/src/lib/libbsp/mips/p4000/startup/Makefile.am b/c/src/lib/libbsp/mips/p4000/startup/Makefile.am
deleted file mode 100644
index 1179dbe3f2..0000000000
--- a/c/src/lib/libbsp/mips/p4000/startup/Makefile.am
+++ /dev/null
@@ -1,54 +0,0 @@
-##
-## $Id$
-##
-
-VPATH = @srcdir@:@srcdir@/../../../shared
-
-PGM = $(ARCH)/startup.rel
-
-C_FILES = bspclean.c bsplibc.c bsppost.c bspstart.c bootcard.c main.c sbrk.c \
- setvec.c inittlb.c gnatinstallhandler.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-S_FILES = idtmem.S idttlb.S
-S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
-
-OBJS = $(C_O_FILES) $(S_O_FILES)
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-$(PGM): $(OBJS)
- $(make-rel)
-
-project_lib_DATA = linkcmds ghlinkcmds
-
-# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
-
-all-local: $(PGM) $(TMPINSTALL_FILES)
-
-EXTRA_DIST = bspclean.c bspstart.c ghlinkcmds idtmem.S idttlb.S inittlb.c \
- linkcmds setvec.c
-
-TMPINSTALL_FILES =
-
-$(PROJECT_LIB)/$(dirstamp):
- @$(mkdir_p) $(PROJECT_LIB)
- @: > $(PROJECT_LIB)/$(dirstamp)
-TMPINSTALL_FILES += $(PROJECT_LIB)/$(dirstamp)
-
-$(PROJECT_LIB)/linkcmds: linkcmds $(PROJECT_LIB)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds
-TMPINSTALL_FILES += $(PROJECT_LIB)/linkcmds
-
-$(PROJECT_LIB)/ghlinkcmds: ghlinkcmds $(PROJECT_LIB)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_LIB)/ghlinkcmds
-TMPINSTALL_FILES += $(PROJECT_LIB)/ghlinkcmds
-
-CLEANFILES = $(TMPINSTALL_FILES)
-
-include $(top_srcdir)/../../../../automake/local.am