summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/mips/p4000/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 11:50:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 11:50:05 +0000
commitb58e3f390ff843af45c408464f432baca8c79162 (patch)
treed41b17241375b748b4a13910eeb3780a4a14311a /c/src/lib/libbsp/mips/p4000/Makefile.am
parent2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-b58e3f390ff843af45c408464f432baca8c79162.tar.bz2
2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. Reflect changes to bsp.am. * include/Makefile.am: Remove. * configure.ac: Reflect changes above. * start/start.S: Comment out string after #endif.
Diffstat (limited to 'c/src/lib/libbsp/mips/p4000/Makefile.am')
-rw-r--r--c/src/lib/libbsp/mips/p4000/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/mips/p4000/Makefile.am b/c/src/lib/libbsp/mips/p4000/Makefile.am
index 2d93f819b8..22ebbab452 100644
--- a/c/src/lib/libbsp/mips/p4000/Makefile.am
+++ b/c/src/lib/libbsp/mips/p4000/Makefile.am
@@ -5,12 +5,20 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = include start startup console liblnk wrapup
+# from the individual .rel files built in other directories
+SUBDIRS = . start startup console liblnk wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs times
+include_HEADERS += include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = times
+
+$(PROJECT_INCLUDE)/coverhd.h: include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am