summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/mips/genmongoosev/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-09 16:18:41 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-09 16:18:41 +0000
commit3ed23846a72c38b615278902d4ee96c7ab73798c (patch)
treeaa7026185a1b113e58a51cec9b09b2ae188d0371 /c/src/lib/libbsp/mips/genmongoosev/Makefile.am
parent2004-01-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-3ed23846a72c38b615278902d4ee96c7ab73798c.tar.bz2
2004-01-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* start/Makefile.am: Remove. * Makefile.am: Merge-in start/Makefile.am. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/mips/genmongoosev/Makefile.am')
-rw-r--r--c/src/lib/libbsp/mips/genmongoosev/Makefile.am24
1 files changed, 19 insertions, 5 deletions
diff --git a/c/src/lib/libbsp/mips/genmongoosev/Makefile.am b/c/src/lib/libbsp/mips/genmongoosev/Makefile.am
index 0a35cb214e..0415838d74 100644
--- a/c/src/lib/libbsp/mips/genmongoosev/Makefile.am
+++ b/c/src/lib/libbsp/mips/genmongoosev/Makefile.am
@@ -4,21 +4,35 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../bsp.am
+
# wrapup is the one that actually builds and installs the library
# from the individual .rel files built in other directories
-SUBDIRS = . start startup clock console timer wrapup
-
-include $(top_srcdir)/../../bsp.am
+SUBDIRS = . startup clock console timer wrapup
nodist_include_HEADERS += $(top_srcdir)/../../shared/include/coverhd.h
-all-local: $(PREINSTALL_FILES)
+S_FILES = start/start.S
+$(ARCH)/%$(LIB_VARIANT).$(OBJEXT): start/start.S $(ARCH)/$(dirstamp)
+ ${CCASCOMPILE} -DASM -o $@ -c $<
+EXTRA_DIST = $(S_FILES) start/regs.S start/mg5.h
-EXTRA_DIST = times
+project_lib_DATA = $(ARCH)/start$(LIB_VARIANT).$(OBJEXT)
+
+all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
+
+EXTRA_DIST += times
+
+TMPINSTALL_FILES =
$(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/coverhd.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
+$(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT): $(ARCH)/start$(LIB_VARIANT).$(OBJEXT) $(PROJECT_LIB)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+TMPINSTALL_FILES += $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am