summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/sim68000/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-08-28 18:20:12 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-08-28 18:20:12 +0000
commitfd3cd3e3e345b7196d35423ea1eb070e5a1b4559 (patch)
tree96458e634f87feae5621ec9c6dbb024a5ffdd60b /c/src/lib/libbsp/m68k/sim68000/configure.ac
parentFix typo in previous change. (diff)
downloadrtems-fd3cd3e3e345b7196d35423ea1eb070e5a1b4559.tar.bz2
2009-08-28 Joel Sherrill <joel.sherrill@OARcorp.com>
* configure.ac, console/conscfg.c: Add CONSOLE_USE_INTERRUPTS.
Diffstat (limited to 'c/src/lib/libbsp/m68k/sim68000/configure.ac')
-rw-r--r--c/src/lib/libbsp/m68k/sim68000/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/m68k/sim68000/configure.ac b/c/src/lib/libbsp/m68k/sim68000/configure.ac
index 4cbf7b926c..a4660c036e 100644
--- a/c/src/lib/libbsp/m68k/sim68000/configure.ac
+++ b/c/src/lib/libbsp/m68k/sim68000/configure.ac
@@ -15,6 +15,16 @@ RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
RTEMS_CANONICALIZE_TOOLS
RTEMS_PROG_CCAS
+## bsp-specific options
+RTEMS_BSPOPTS_SET([CONSOLE_USE_INTERRUPTS],[*],[0])
+RTEMS_BSPOPTS_HELP([CONSOLE_USE_INTERRUPTS],
+[The erc32 console driver can operate in either polled or interrupt mode.
+Under the simulator (especially when FAST_UART is defined), polled seems to operate
+better. It is common for a task to print a line (like the end of test message) and
+then exit. In this case, the program returns control to the simulator command line
+before the program has even queued the output to the uart. Thus sis has no chance
+of getting the data out.])
+
RTEMS_BSP_BOOTCARD_OPTIONS
RTEMS_BSP_CLEANUP_OPTIONS(0, 0)