summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/mvme162/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 14:26:12 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 14:26:12 +0000
commitd688b2ca0cda16ff93ae6cea8b9721608f79ac77 (patch)
treec40d08191da94e4d5e6f8174fc1992fdf38aef5e /c/src/lib/libbsp/m68k/mvme162/Makefile.am
parent2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-d688b2ca0cda16ff93ae6cea8b9721608f79ac77.tar.bz2
2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. Reflect changes to bsp.am. * include/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/m68k/mvme162/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/mvme162/Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/m68k/mvme162/Makefile.am b/c/src/lib/libbsp/m68k/mvme162/Makefile.am
index e600576604..00c9238592 100644
--- a/c/src/lib/libbsp/m68k/mvme162/Makefile.am
+++ b/c/src/lib/libbsp/m68k/mvme162/Makefile.am
@@ -9,11 +9,11 @@ ACLOCAL_AMFLAGS = -I ../../../../aclocal
# The MVME162 has 2 z8530's to yield four serial ports.
# The application can access these by referencing the consolex driver
# with "CONSOLEX_DRIVER_TABLE_ENTRY" in the driver table definition,
-# in place of "CONSOLE_DRIVER_TABLE_ENTRY". See consolex/cTest.c for
+# in place of "CONSOLE_DRIVER_TABLE_ENTRY". See consolex/cTest.c for
# an example.
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
+# from the individual .rel files built in other directories
SUBDIRS = . start startup clock console timer tod network wrapup tools
include $(top_srcdir)/../../bsp.am
@@ -28,5 +28,22 @@ all-local: $(PREINSTALL_FILES)
EXTRA_DIST = times
+$(PROJECT_INCLUDE)/coverhd.h: include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
+
+$(PROJECT_INCLUDE)/page_table.h: include/page_table.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/page_table.h
+
+$(PROJECT_INCLUDE)/tod.h: include/tod.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/tod.h
+
+$(PROJECT_INCLUDE)/mvme16x_hw.h: \
+ $(top_srcdir)/../shared/mvme/include/mvme16x_hw.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/mvme16x_hw.h
+
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am