summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/mvme162/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-14 01:30:31 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-14 01:30:31 +0000
commit2d86d78f965efaee5832e1d4bff1754085baae8f (patch)
treeb95367978c95bb7d64a5796edb8db3848f5c3727 /c/src/lib/libbsp/m68k/mvme162/Makefile.am
parent2004-01-13 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-2d86d78f965efaee5832e1d4bff1754085baae8f.tar.bz2
2004-01-14 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* start/.cvsignore: Remove. * start/Makefile.am: Remove. * Makefile.am: Merge-in start/Makefile.am. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/m68k/mvme162/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/mvme162/Makefile.am19
1 files changed, 15 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/m68k/mvme162/Makefile.am b/c/src/lib/libbsp/m68k/mvme162/Makefile.am
index 90d078c506..82b4df11b4 100644
--- a/c/src/lib/libbsp/m68k/mvme162/Makefile.am
+++ b/c/src/lib/libbsp/m68k/mvme162/Makefile.am
@@ -4,6 +4,9 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../bsp.am
+
# consolex is a predecessor of the termios and libchip concepts.
# It is no longer being compiled into the source.
# The MVME162 has 2 z8530's to yield four serial ports.
@@ -14,9 +17,7 @@ ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
# from the individual .rel files built in other directories
-SUBDIRS = . start startup clock console timer tod network wrapup tools
-
-include $(top_srcdir)/../../bsp.am
+SUBDIRS = . startup clock console timer tod network wrapup tools
include_HEADERS += include/coverhd.h
include_HEADERS += include/page_table.h
@@ -24,7 +25,13 @@ include_HEADERS += include/tod.h
nodist_include_HEADERS += $(top_srcdir)/../shared/mvme/mvme16x_hw.h
-all-local: $(PREINSTALL_FILES)
+m68k_shared_S_FILES = $(top_srcdir)/../../m68k/shared/start.S
+$(ARCH)/%$(LIB_VARIANT).$(OBJEXT): $(top_srcdir)/../../m68k/shared/start.S $(ARCH)/$(dirstamp)
+ ${CCASCOMPILE} -DASM -o $@ -c $<
+
+project_lib_DATA = $(ARCH)/start$(LIB_VARIANT).$(OBJEXT)
+
+all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
EXTRA_DIST = times
@@ -44,5 +51,9 @@ $(PROJECT_INCLUDE)/mvme16x_hw.h: $(top_srcdir)/../shared/mvme/mvme16x_hw.h $(PRO
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/mvme16x_hw.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/mvme16x_hw.h
+$(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT): $(ARCH)/start$(LIB_VARIANT).$(OBJEXT) $(PROJECT_LIB)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+TMPINSTALL_FILES += $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am