summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/mvme147s/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-14 10:42:18 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-14 10:42:18 +0000
commit5146f3d6911af03aae505211058518a2e5d2f53b (patch)
tree32f32841b6010cdb5643a36cc18dd76f1c38b8c2 /c/src/lib/libbsp/m68k/mvme147s/Makefile.am
parent2004-01-14 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-5146f3d6911af03aae505211058518a2e5d2f53b.tar.bz2
2004-01-14 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* start/.cvsignore: Remove. * start/Makefile.am: Remove. * Makefile.am: Merge-in start/Makefile.am. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/m68k/mvme147s/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/mvme147s/Makefile.am21
1 files changed, 17 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/m68k/mvme147s/Makefile.am b/c/src/lib/libbsp/m68k/mvme147s/Makefile.am
index 6f201fc72f..5a982f7282 100644
--- a/c/src/lib/libbsp/m68k/mvme147s/Makefile.am
+++ b/c/src/lib/libbsp/m68k/mvme147s/Makefile.am
@@ -4,23 +4,36 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../bsp.am
+
# wrapup is the one that actually builds and installs the library
# from the individual .rel files built in other directories
-SUBDIRS = . start startup clock console timer shmsupp wrapup
-
-include $(top_srcdir)/../../bsp.am
+SUBDIRS = . startup clock console timer shmsupp wrapup
include_HEADERS += include/coverhd.h
-all-local: $(PREINSTALL_FILES)
+$(ARCH)/%$(LIB_VARIANT).$(OBJEXT): $(top_srcdir)/../../m68k/shared/start.S $(ARCH)/$(dirstamp)
+ ${CCASCOMPILE} -DASM -o $@ -c $<
+
+project_lib_DATA = $(ARCH)/start$(LIB_VARIANT).$(OBJEXT)
+
+all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
EXTRA_DIST = times
+TMPINSTALL_FILES =
+
$(PROJECT_INCLUDE)/coverhd.h: include/coverhd.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/coverhd.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
+$(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT): $(ARCH)/start$(LIB_VARIANT).$(OBJEXT) $(PROJECT_LIB)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+TMPINSTALL_FILES += $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+
CLEANFILES = $(PREINSTALL_FILES)
+CLEANFILES += $(TMPINSTALL_FILES)
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am