summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
commit4e36a2f133c68aaf637e166385eff1a05b59f38e (patch)
tree47520e4fbb8b685c25ae2909cf2a12287be4268b /c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am
parentPatch rtems-rc-20000118-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4e36a2f133c68aaf637e166385eff1a05b59f38e.tar.bz2
Patches rtems-rc-20000118-3.diff and rtems-rc-20000118-4.diff from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> that contain: * Modifications, (minor) corrections, cleanups to most existing Makefile.ams * Adds automake support to all remaining BSPs which have not yet been converted to automake. * Makefile.am for all remaining wrapup/Makefile.ams
Diffstat (limited to 'c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am b/c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am
index 7932696f8c..0591d294b2 100644
--- a/c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am
+++ b/c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am
@@ -6,7 +6,6 @@ AUTOMAKE_OPTIONS = foreign 1.4
PGM = ${ARCH}/shmsupp.rel
-## C source names
C_FILES = addrconv.c getcfg.c lock.c mpisr.c
C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
@@ -23,13 +22,11 @@ $(PGM): ${OBJS}
$(make-rel)
if HAS_MP
-all-local: ${ARCH} $(PGM)
-else
-all-local:
+all-local: ${ARCH} $(OBJS) $(PGM)
endif
# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
-EXTRA_DIST = $(C_FILES)
+EXTRA_DIST = addrconv.c getcfg.c lock.c mpisr.c
include $(top_srcdir)/../../../../../../automake/local.am