summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/mvme136/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-05-15 15:52:00 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-05-15 15:52:00 +0000
commit19f4a3491451cc77a8eebf583b144e78b58a3b61 (patch)
tree76e16401b8249aaca0be6af5c1a4af6c35ea17ff /c/src/lib/libbsp/m68k/mvme136/configure.ac
parentdisabled debugging output (diff)
downloadrtems-19f4a3491451cc77a8eebf583b144e78b58a3b61.tar.bz2
2008-05-15 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac, startup/bspstart.c: Add capability for bootcard.c BSP Initialization Framework to ask the BSP where it has memory for the RTEMS Workspace and C Program Heap. These collectively are referred to as work area. If the BSP supports this, then it does not have to include code to split the available memory between the two areas. This reduces the amount of code in the BSP specific bspstart.c file. Additionally, the shared framework can dirty the work area memory. Until most/all BSPs support this new capability, if the BSP supports this, it should call RTEMS_BSP_BOOTCARD_HANDLES_RAM_ALLOCATION from its configure.ac. When the transition is complete, this autoconf macro can be removed.
Diffstat (limited to 'c/src/lib/libbsp/m68k/mvme136/configure.ac')
-rw-r--r--c/src/lib/libbsp/m68k/mvme136/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/m68k/mvme136/configure.ac b/c/src/lib/libbsp/m68k/mvme136/configure.ac
index c6e4326ee7..2d8f12787d 100644
--- a/c/src/lib/libbsp/m68k/mvme136/configure.ac
+++ b/c/src/lib/libbsp/m68k/mvme136/configure.ac
@@ -15,6 +15,8 @@ RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
RTEMS_CANONICALIZE_TOOLS
RTEMS_PROG_CCAS
+RTEMS_BSP_BOOTCARD_HANDLES_RAM_ALLOCATION
+
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile])
AC_OUTPUT