summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/mcf5225x/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-04-05 17:06:57 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-04-05 17:06:57 +0000
commitfe32208840b1eb215e5925a31ef79d77709082fa (patch)
tree5eddbde5f896fdb16352e69940b6e1c4c543f408 /c/src/lib/libbsp/m68k/mcf5225x/configure.ac
parent2010-04-04 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-fe32208840b1eb215e5925a31ef79d77709082fa.tar.bz2
2010-04-05 Thomas Znidar <t.znidar@embed-it.com>
* ChangeLog, Makefile.am, README, bsp_specs, configure.ac, gdb-init, preinstall.am, clock/clock.c, console/console.c, console/debugio.c, include/bsp.h, include/tm27.h, make/custom/mcf5225x.cfg, start/start.S, startup/bspclean.c, startup/bspstart.c, startup/init5225x.c, startup/linkcmds, timer/timer.c: New files.
Diffstat (limited to 'c/src/lib/libbsp/m68k/mcf5225x/configure.ac')
-rw-r--r--c/src/lib/libbsp/m68k/mcf5225x/configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/m68k/mcf5225x/configure.ac b/c/src/lib/libbsp/m68k/mcf5225x/configure.ac
new file mode 100644
index 0000000000..30644b9b44
--- /dev/null
+++ b/c/src/lib/libbsp/m68k/mcf5225x/configure.ac
@@ -0,0 +1,27 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ(2.60)
+AC_INIT([rtems-c-src-lib-libbsp-m68k-dpu],[_RTEMS_VERSION],[http://www.rtems.org/bugzilla])
+AC_CONFIG_SRCDIR([bsp_specs])
+RTEMS_TOP(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE([no-define nostdinc foreign 1.10])
+RTEMS_BSP_CONFIGURE
+
+RTEMS_PROG_CC_FOR_TARGET
+RTEMS_CANONICALIZE_TOOLS
+RTEMS_PROG_CCAS
+
+RTEMS_BSP_BOOTCARD_HANDLES_RAM_ALLOCATION
+RTEMS_BSP_BOOTCARD_OPTIONS
+RTEMS_BSP_CLEANUP_OPTIONS(0, 1)
+
+RTEMS_CHECK_NETWORKING
+AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "lwip")
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT