summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/idp/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-06 23:49:14 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-06 23:49:14 +0000
commit2850606f8eec8494819422d43c072f759df42f69 (patch)
treebbfc9e9c0977eca853db7869fa618c8c19e96459 /c/src/lib/libbsp/m68k/idp/Makefile.am
parent2004-01-06 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-2850606f8eec8494819422d43c072f759df42f69.tar.bz2
2004-01-06 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* start/Makefile.am: Remove. * Makefile.am: Merge-in start/Makefile.am. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/m68k/idp/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/idp/Makefile.am21
1 files changed, 17 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/m68k/idp/Makefile.am b/c/src/lib/libbsp/m68k/idp/Makefile.am
index e5805b0b94..fed1d199e9 100644
--- a/c/src/lib/libbsp/m68k/idp/Makefile.am
+++ b/c/src/lib/libbsp/m68k/idp/Makefile.am
@@ -4,20 +4,29 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../bsp.am
+
# wrapup is the one that actually builds and installs the library
# from the individual .rel files built in other directories
-SUBDIRS = . start startup clock console timer wrapup
-
-include $(top_srcdir)/../../bsp.am
+SUBDIRS = . startup clock console timer wrapup
include_HEADERS += include/leds.h
nodist_include_HEADERS += $(top_srcdir)/../../shared/include/coverhd.h
-all-local: $(PREINSTALL_FILES)
+m68k_shared_S_FILES = $(top_srcdir)/../../m68k/shared/start.S
+$(ARCH)/%$(LIB_VARIANT).$(OBJEXT): $(top_srcdir)/../../m68k/shared/start.S $(ARCH)/$(dirstamp)
+ ${CCASCOMPILE} -DASM -o $@ -c $<
+
+project_lib_DATA = $(ARCH)/start$(LIB_VARIANT).$(OBJEXT)
+
+all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
EXTRA_DIST = include/README
EXTRA_DIST += times
+TMPINSTALL_FILES =
+
$(PROJECT_INCLUDE)/leds.h: include/leds.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/leds.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/leds.h
@@ -26,5 +35,9 @@ $(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h $(PRO
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/coverhd.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
+$(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT): $(ARCH)/start$(LIB_VARIANT).$(OBJEXT) $(PROJECT_LIB)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+TMPINSTALL_FILES += $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am