summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/gen68302/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-06-14 12:43:18 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-06-14 12:43:18 +0000
commitebf3adc76f5b79d58191185440d843d72376b013 (patch)
tree3412390a7614461e00a8325f250f31d75c9a5330 /c/src/lib/libbsp/m68k/gen68302/include/Makefile.am
parent2001-05-25 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-ebf3adc76f5b79d58191185440d843d72376b013.tar.bz2
2001-05-26 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.in: Add bspopts.h. * include/.cvsignore: Add bspopts.h*, stamp-h*. * include/Makefile.am: Use *_HEADERS instead of *H_FILES. * include/bsp.h: Include bspopts.h.
Diffstat (limited to 'c/src/lib/libbsp/m68k/gen68302/include/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/gen68302/include/Makefile.am16
1 files changed, 4 insertions, 12 deletions
diff --git a/c/src/lib/libbsp/m68k/gen68302/include/Makefile.am b/c/src/lib/libbsp/m68k/gen68302/include/Makefile.am
index fd41652289..709755bd95 100644
--- a/c/src/lib/libbsp/m68k/gen68302/include/Makefile.am
+++ b/c/src/lib/libbsp/m68k/gen68302/include/Makefile.am
@@ -4,25 +4,17 @@
AUTOMAKE_OPTIONS = foreign 1.4
-H_FILES = bsp.h coverhd.h m302_int.h
+include_HEADERS = bsp.h coverhd.h m302_int.h bspopts.h
$(PROJECT_INCLUDE):
$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/bsp.h: bsp.h
+$(PROJECT_INCLUDE)/%.h: %.h
$(INSTALL_DATA) $< $@
-$(PROJECT_INCLUDE)/m302_int.h: m302_int.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/coverhd.h: coverhd.h
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/bsp.h \
- $(PROJECT_INCLUDE)/coverhd.h $(PROJECT_INCLUDE)/m302_int.h
+TMPINSTALL_FILES += $(PROJECT_INCLUDE) \
+ $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
all-local: $(TMPINSTALL_FILES)
-EXTRA_DIST = bsp.h coverhd.h m302_int.h
-
include $(top_srcdir)/../../../../../../automake/local.am