summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/efi332/startup/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-12 12:56:07 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-12 12:56:07 +0000
commit50bb7627337aa780c4e8e6f3cbded85d2c80381b (patch)
tree0f6b313ab0e87a1471f42b4ee243130e5bf1b334 /c/src/lib/libbsp/m68k/efi332/startup/Makefile.am
parent2000-10-12 John S Gwynne <jgwynne@mrcday.com> (diff)
downloadrtems-50bb7627337aa780c4e8e6f3cbded85d2c80381b.tar.bz2
2000-10-12 John S Gwynne <jgwynne@mrcday.com>
* start/start.c: Modified to support generation of ram_init. * start/ram_init.ld, BSP/start/ram_init.sed: New files. These changes enable RTEMS to automatically generate the ram_init file used by gdb with the BDM patches. The 332 has on-board chip select lines (for RAM and FLASH) that must be configured before use of these peripherals. These patches parse data from start.c where the chip select lines are configured in the runtime executable and automatically generates the gdb initialization file using the same settings. A great time saver. A similar file, ram_init_FW (flash writable), is also generated that the flash programming tool uses. * start/Makefile.am: Modified to support above. * CPU/sim.h: Modified to support above. * startup/except_vect_332_ROM.S: Moved to start so it would not be included in libbsp.a. Moving it to start ensures it is available as a single object file. * start/except_vect_332_ROM.S: Moved from startup. * startup/linkcmds, startup/linkcmds_ROM: Fixes to the memory map shown in the comments.
Diffstat (limited to 'c/src/lib/libbsp/m68k/efi332/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/efi332/startup/Makefile.am12
1 files changed, 3 insertions, 9 deletions
diff --git a/c/src/lib/libbsp/m68k/efi332/startup/Makefile.am b/c/src/lib/libbsp/m68k/efi332/startup/Makefile.am
index d8fa5fd721..30b383f156 100644
--- a/c/src/lib/libbsp/m68k/efi332/startup/Makefile.am
+++ b/c/src/lib/libbsp/m68k/efi332/startup/Makefile.am
@@ -12,7 +12,7 @@ C_FILES = bsplibc.c bsppost.c bspstart.c bspclean.c bootcard.c \
m68kpretaskinghook.c main.c sbrk.c setvec.c gnatinstallhandler.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-S_FILES = except_vect_332_ROM.S
+S_FILES =
S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
OBJS = $(C_O_FILES) $(S_O_FILES)
@@ -37,20 +37,14 @@ $(PROJECT_RELEASE)/lib/linkcmds: linkcmds
$(PROJECT_RELEASE)/lib/linkcmds_ROM: linkcmds_ROM
$(INSTALL_DATA) $< $@
-$(PROJECT_RELEASE)/lib/except_vect_332_ROM$(LIB_VARIANT).o: \
- $(ARCH)/except_vect_332_ROM.o
- $(INSTALL_DATA) $< $@
-
# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds \
- $(PROJECT_RELEASE)/lib/linkcmds_ROM \
- $(PROJECT_RELEASE)/lib/except_vect_332_ROM$(LIB_VARIANT).o
+ $(PROJECT_RELEASE)/lib/linkcmds_ROM
all-local: $(ARCH) $(OBJS) $(PGM) $(TMPINSTALL_FILES)
.PRECIOUS: $(PGM)
-EXTRA_DIST = bspclean.c bspstart.c except_vect_332_ROM.S linkcmds \
- linkcmds_ROM
+EXTRA_DIST = bspclean.c bspstart.c linkcmds linkcmds_ROM
include $(top_srcdir)/../../../../../../automake/local.am