summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/efi332/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 14:26:12 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 14:26:12 +0000
commitd688b2ca0cda16ff93ae6cea8b9721608f79ac77 (patch)
treec40d08191da94e4d5e6f8174fc1992fdf38aef5e /c/src/lib/libbsp/m68k/efi332/Makefile.am
parent2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-d688b2ca0cda16ff93ae6cea8b9721608f79ac77.tar.bz2
2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. Reflect changes to bsp.am. * include/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/m68k/efi332/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/efi332/Makefile.am20
1 files changed, 17 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/m68k/efi332/Makefile.am b/c/src/lib/libbsp/m68k/efi332/Makefile.am
index 97b2304596..1c5058bfc1 100644
--- a/c/src/lib/libbsp/m68k/efi332/Makefile.am
+++ b/c/src/lib/libbsp/m68k/efi332/Makefile.am
@@ -5,12 +5,26 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = . include start startup clock console spurious timer wrapup
+# from the individual .rel files built in other directories
+SUBDIRS = . start startup clock console spurious timer wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs times
+include_HEADERS += include/efi332.h
+
+nodist_include_HEADERS += $(top_srcdir)/../../shared/include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = times
+
+$(PROJECT_INCLUDE)/efi332.h: include/efi332.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/efi332.h
+
+$(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am