summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m32r/m32rsim/Makefile.am
diff options
context:
space:
mode:
authorAun-Ali Zaidi <admin@kodeit.net>2015-12-09 20:21:03 -0600
committerSebastian Huber <sebastian.huber@embedded-brains.de>2015-12-10 09:28:47 +0100
commitf7c47a6880aea022b12f7f553df070d6f7ec0702 (patch)
tree35717f9fb75d13d578e66965a9db2eab2f0f4fe2 /c/src/lib/libbsp/m32r/m32rsim/Makefile.am
parentbsps: Delete superfluous bsp_pretasking_hook() (diff)
downloadrtems-f7c47a6880aea022b12f7f553df070d6f7ec0702.tar.bz2
m32r/m32rsim: Remove
updates #2447.
Diffstat (limited to 'c/src/lib/libbsp/m32r/m32rsim/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m32r/m32rsim/Makefile.am48
1 files changed, 0 insertions, 48 deletions
diff --git a/c/src/lib/libbsp/m32r/m32rsim/Makefile.am b/c/src/lib/libbsp/m32r/m32rsim/Makefile.am
deleted file mode 100644
index 12cd67d7f8..0000000000
--- a/c/src/lib/libbsp/m32r/m32rsim/Makefile.am
+++ /dev/null
@@ -1,48 +0,0 @@
-ACLOCAL_AMFLAGS = -I ../../../../aclocal
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../bsp.am
-
-include_bspdir = $(includedir)/bsp
-
-dist_project_lib_DATA = bsp_specs
-
-include_HEADERS = include/bsp.h
-include_HEADERS += include/tm27.h
-
-nodist_include_HEADERS = include/bspopts.h
-nodist_include_bsp_HEADERS = ../../shared/include/bootcard.h
-nodist_include_bsp_HEADERS += ../../shared/include/console-polled.h
-DISTCLEANFILES = include/bspopts.h
-noinst_PROGRAMS =
-
-nodist_include_HEADERS += ../../shared/include/coverhd.h
-
-EXTRA_DIST = start/start.S
-start.$(OBJEXT): start/start.S
- $(CPPASCOMPILE) -o $@ -c $<
-project_lib_DATA = start.$(OBJEXT)
-
-dist_project_lib_DATA += startup/linkcmds
-
-startup_SOURCES = ../../shared/bspclean.c ../../shared/bsplibc.c \
- ../../shared/bsppredriverhook.c \
- ../../shared/bspgetworkarea.c ../../shared/bsppost.c \
- ../../shared/bspstart.c ../../shared/bootcard.c ../../shared/sbrk.c \
- ../../shared/gnatinstallhandler.c startup/bspreset.c
-clock_SOURCES = ../../shared/clock_driver_simidle.c
-console_SOURCES = ../../shared/console-polled.c console/console-io.c \
- console/trap0.S
-timer_SOURCES = ../../shared/timerstub.c
-
-noinst_LIBRARIES = libbsp.a
-libbsp_a_SOURCES = $(startup_SOURCES) $(clock_SOURCES) $(console_SOURCES) \
- $(timer_SOURCES)
-
-# Cache
-libbsp_a_SOURCES += ../../../libcpu/shared/src/cache_manager.c
-libbsp_a_SOURCES += ../../shared/include/cache_.h
-libbsp_a_CPPFLAGS = -I$(srcdir)/../../shared/include
-
-include $(srcdir)/preinstall.am
-include $(top_srcdir)/../../../../automake/local.am