summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m32c/m32cbsp/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-10-02 21:34:36 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-10-02 21:34:36 +0000
commit0fd07a10eb2c1b928d32744826c5be32e6f28675 (patch)
treec030d59484b98272a9aec35da28590e2d66997dd /c/src/lib/libbsp/m32c/m32cbsp/configure.ac
parent2008-10-02 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-0fd07a10eb2c1b928d32744826c5be32e6f28675.tar.bz2
2008-10-02 Joel Sherrill <joel.sherrill@oarcorp.com>
* .cvsignore, ChangeLog, Makefile.am, bsp_specs, configure.ac, preinstall.am, console/console-io.c, console/syscalls.S, include/.cvsignore, include/bsp.h, start/start.S, startup/bspstart.c, startup/crtn.S, startup/linkcmds, timer/timer.c, tools/.cvsignore, tools/Makefile.am, tools/configure.ac, tools/runtest.in: New files.
Diffstat (limited to 'c/src/lib/libbsp/m32c/m32cbsp/configure.ac')
-rw-r--r--c/src/lib/libbsp/m32c/m32cbsp/configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/m32c/m32cbsp/configure.ac b/c/src/lib/libbsp/m32c/m32cbsp/configure.ac
new file mode 100644
index 0000000000..9f1ac113ed
--- /dev/null
+++ b/c/src/lib/libbsp/m32c/m32cbsp/configure.ac
@@ -0,0 +1,24 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ(2.60)
+AC_INIT([rtems-c-src-lib-libbsp-h8300-h8sim],[_RTEMS_VERSION],[http://www.rtems.org/bugzilla])
+AC_CONFIG_SRCDIR([bsp_specs])
+RTEMS_TOP(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE([no-define nostdinc foreign 1.10])
+RTEMS_BSP_CONFIGURE
+
+RTEMS_CONFIG_BUILD_SUBDIRS(tools)
+
+RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
+RTEMS_CANONICALIZE_TOOLS
+RTEMS_PROG_CCAS
+
+BSP_BOOTCARD_OPTIONS
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT