summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/lm32/milkymist/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-08-20 21:22:27 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-08-20 21:22:27 +0000
commit8affb5a9ed3661f67c8394094df617d004a19334 (patch)
tree188819f5aeb0aa92c18e100032a0c44984a77fee /c/src/lib/libbsp/lm32/milkymist/Makefile.am
parent2010-08-20 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-8affb5a9ed3661f67c8394094df617d004a19334.tar.bz2
2010-08-20 <yann.sionneau@telecom-sudparis.eu>
Add Milkymist BSP developed as part of GSOC 2010. * ChangeLog, Makefile.am, README, bsp_specs, configure.ac, preinstall.am, Documentation/uart.txt, include/.cvsignore, include/bsp.h, include/system_conf.h, include/tm27.h, make/custom/milkymist.cfg, startup/linkcmds: New files.
Diffstat (limited to 'c/src/lib/libbsp/lm32/milkymist/Makefile.am')
-rw-r--r--c/src/lib/libbsp/lm32/milkymist/Makefile.am69
1 files changed, 69 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/lm32/milkymist/Makefile.am b/c/src/lib/libbsp/lm32/milkymist/Makefile.am
new file mode 100644
index 0000000000..0e09d57949
--- /dev/null
+++ b/c/src/lib/libbsp/lm32/milkymist/Makefile.am
@@ -0,0 +1,69 @@
+##
+## $Id$
+##
+
+ACLOCAL_AMFLAGS = -I ../../../../aclocal
+
+include $(top_srcdir)/../../../../automake/compile.am
+
+include_bspdir = $(includedir)/bsp
+
+dist_project_lib_DATA = bsp_specs
+
+include_HEADERS = include/bsp.h
+include_HEADERS += include/tm27.h
+
+nodist_include_HEADERS = include/bspopts.h
+nodist_include_bsp_HEADERS = ../../shared/include/bootcard.h
+DISTCLEANFILES = include/bspopts.h
+
+noinst_PROGRAMS =
+
+include_HEADERS += ../../shared/include/coverhd.h
+include_HEADERS += include/system_conf.h
+
+noinst_LIBRARIES = libbspstart.a
+libbspstart_a_SOURCES = ../../lm32/shared/start/start.S
+project_lib_DATA = start.$(OBJEXT)
+
+dist_project_lib_DATA += startup/linkcmds
+
+noinst_LIBRARIES += libbsp.a
+libbsp_a_SOURCES =
+libbsp_a_LIBADD =
+
+# startup
+libbsp_a_SOURCES += ../../shared/bspclean.c ../../shared/bsplibc.c \
+ ../../shared/bsppost.c ../shared/startup/bspstart.c \
+ ../../shared/bspreset.c ../../shared/bsppretaskinghook.c \
+ ../../shared/bspgetworkarea.c ../../shared/bootcard.c \
+ ../../shared/sbrk.c ../../lm32/shared/startup/setvec.c \
+ ../../shared/gnatinstallhandler.c
+
+# clock
+
+libbsp_a_SOURCES += ../../lm32/shared/milkymist_clock/ckinit.c
+
+# console
+libbsp_a_SOURCES += ../../lm32/shared/milkymist_console/console.c \
+ ../../lm32/shared/milkymist_console/uart.c
+# timer
+libbsp_a_SOURCES += ../../lm32/shared/milkymist_timer/timer.c
+
+# framebuffer
+libbsp_a_SOURCES += ../../lm32/shared/milkymist_framebuffer/framebuffer.c
+
+# gpio
+libbsp_a_SOURCES += ../../lm32/shared/milkymist_gpio/gpio.c
+
+if HAS_NETWORKING
+noinst_PROGRAMS += network.rel
+network_rel_SOURCES = ../../lm32/shared/milkymist_networking/network.c \
+ ../../lm32/shared/milkymist_networking/mm_crc32.c
+network_rel_CPPFLAGS = $(AM_CPPFLAGS) -D__INSIDE_RTEMS_BSD_TCPIP_STACK__
+network_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+libbsp_a_LIBADD += network.rel
+endif
+
+include $(srcdir)/preinstall.am
+include $(top_srcdir)/../../../../automake/local.am