summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/lm32/lm32_evr/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-02-26 20:45:44 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-02-26 20:45:44 +0000
commitbe9f085602d3bd2c419c3226e73f8c33b6b86186 (patch)
tree2ec07d86eead1de45b5a611bba0459595be6f8c1 /c/src/lib/libbsp/lm32/lm32_evr/configure.ac
parent2009-02-26 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-be9f085602d3bd2c419c3226e73f8c33b6b86186.tar.bz2
2009-02-26 Joel Sherrill <joel.sherrill@oarcorp.com>
* configure.ac, include/bsp.h: Run better on simulator. Timer is probably not right yet but
Diffstat (limited to 'c/src/lib/libbsp/lm32/lm32_evr/configure.ac')
-rw-r--r--c/src/lib/libbsp/lm32/lm32_evr/configure.ac19
1 files changed, 11 insertions, 8 deletions
diff --git a/c/src/lib/libbsp/lm32/lm32_evr/configure.ac b/c/src/lib/libbsp/lm32/lm32_evr/configure.ac
index 557f30d06e..39f7187382 100644
--- a/c/src/lib/libbsp/lm32/lm32_evr/configure.ac
+++ b/c/src/lib/libbsp/lm32/lm32_evr/configure.ac
@@ -19,18 +19,21 @@ RTEMS_CHECK_NETWORKING
AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
-RTEMS_BSPOPTS_SET([SIMULATOR_FAST_IDLE],[*],[])
-RTEMS_BSPOPTS_HELP([SIMULATOR_FAST_IDLE],
-[If defined, speed up the clock ticks while the idle task is running so
- time spent in the idle task is minimized. This significantly reduces
- the wall time required to execute the RTEMS test suites.])
-
-RTEMS_BSPOPTS_SET([BSP_PRESS_KEY_FOR_RESET],[*],[1])
+RTEMS_BSPOPTS_SET([ON_SIMULATOR],[*],[])
+RTEMS_BSPOPTS_HELP([ON_SIMULATOR],
+[If defined, this indicates the BSP is being built to run on the lm32
+ simulator in GDB. This enables fast idle support which speeds up the
+ clock ticks while the idle task is running so time spent in the idle
+ task is minimized. This significantly reduces the wall time required
+ to execute the RTEMS test suites. It also enables a special exit and
+ alternate printk support.])
+
+RTEMS_BSPOPTS_SET([BSP_PRESS_KEY_FOR_RESET],[*],[0])
RTEMS_BSPOPTS_HELP([BSP_PRESS_KEY_FOR_RESET],
[If defined, print a message and wait until pressed before resetting
board when application exits.])
-RTEMS_BSPOPTS_SET([BSP_RESET_BOARD_AT_EXIT],[*],[1])
+RTEMS_BSPOPTS_SET([BSP_RESET_BOARD_AT_EXIT],[*],[0])
RTEMS_BSPOPTS_HELP([BSP_RESET_BOARD_AT_EXIT],
[If defined, reset the board when the application exits.])