summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i960/i960sim/startup/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-12 16:34:46 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-12 16:34:46 +0000
commit68c498f47761a00aee669aeb52a8e473c4d802ba (patch)
tree79d2517b87d95d739067c9b3764cc6f02496c649 /c/src/lib/libbsp/i960/i960sim/startup/Makefile.am
parentMerge lossage. Apparently the DOS/UNIX CRLF issue got lost. (diff)
downloadrtems-68c498f47761a00aee669aeb52a8e473c4d802ba.tar.bz2
Added i960sim BSP which (ignoring the 3 instructions not supported
by gdb 5.0's i960 simulator) is enough to run hello world.
Diffstat (limited to 'c/src/lib/libbsp/i960/i960sim/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/i960/i960sim/startup/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/i960/i960sim/startup/Makefile.am b/c/src/lib/libbsp/i960/i960sim/startup/Makefile.am
new file mode 100644
index 0000000000..fec84657aa
--- /dev/null
+++ b/c/src/lib/libbsp/i960/i960sim/startup/Makefile.am
@@ -0,0 +1,39 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+VPATH = @srcdir@:@srcdir@/../../../shared
+
+PGM = $(ARCH)/startup.rel
+
+C_FILES = bspclean.c bsplibc.c bsppost.c bspstart.c bootcard.c main.c sbrk.c \
+ gnatinstallhandler.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(OBJS)
+ $(make-rel)
+
+$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
+ $(INSTALL_DATA) $< $@
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds
+
+all-local: $(ARCH) $(OBJS) $(PGM) $(TMPINSTALL_FILES)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = bspclean.c bspstart.c exit.c linkcmds setvec.c
+
+include $(top_srcdir)/../../../../../../automake/local.am