summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/start/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-12 16:38:56 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-12 16:38:56 +0000
commit69537ca9eccfa12142dea588fa34b70a6d220705 (patch)
tree6480f82ae96a1614df3d0719635213e194dc66ae /c/src/lib/libbsp/i386/pc386/start/Makefile.am
parentCalled symbol table ".nm" not .num like every other BSP. (diff)
downloadrtems-69537ca9eccfa12142dea588fa34b70a6d220705.tar.bz2
Patch rtems-rc-20000104-16.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts the libbsp/i386 subdirectory to full automake.
Diffstat (limited to 'c/src/lib/libbsp/i386/pc386/start/Makefile.am')
-rw-r--r--c/src/lib/libbsp/i386/pc386/start/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/start/Makefile.am b/c/src/lib/libbsp/i386/pc386/start/Makefile.am
new file mode 100644
index 0000000000..32ef8a28df
--- /dev/null
+++ b/c/src/lib/libbsp/i386/pc386/start/Makefile.am
@@ -0,0 +1,48 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGMS = ${ARCH}/start.o ${ARCH}/start16.bin
+
+# Assembly source names, if any, go here -- minus the .S
+S_FILES = start16.S start.S
+S_O_FILES = $(S_FILES:%.S=${ARCH}/%.o)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+if RTEMS_GAS_CODE16
+AM_CPPFLAGS += -DNEW_GAS
+endif
+
+LINKCMDS = $(top_srcdir)/startup/linkcmds
+
+${ARCH}/start16.o: start16.S
+ ${COMPILE.S} $(AM_CPPFLAGS) -DHEADERADDR=$(HEADERADDR) -o $@ $<
+
+${ARCH}/start16.bin: ${ARCH}/start16.o
+ $(LD) -N -T $(LINKCMDS) -Ttext $(START16ADDR) -e start16 -nostdlib \
+ --oformat=elf32-i386 -o $(basename $@).obj $(basename $@).o
+ $(OBJCOPY) -O binary $(basename $@).obj $@
+
+$(PROJECT_RELEASE)/lib/start16$(LIB_VARIANT).bin: ${ARCH}/start16.bin
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_RELEASE)/lib/start$(LIB_VARIANT).o: $(ARCH)/start.o
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES += \
+$(PROJECT_RELEASE)/lib/start16$(LIB_VARIANT).bin \
+$(PROJECT_RELEASE)/lib/start$(LIB_VARIANT).o
+
+all-local: $(ARCH) $(TMPINSTALL_FILES)
+
+EXTRA_DIST = start.S start16.S
+
+include $(top_srcdir)/../../../../../../automake/local.am