summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-12 16:38:56 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-12 16:38:56 +0000
commit69537ca9eccfa12142dea588fa34b70a6d220705 (patch)
tree6480f82ae96a1614df3d0719635213e194dc66ae /c/src/lib/libbsp/i386/pc386/include/Makefile.am
parentCalled symbol table ".nm" not .num like every other BSP. (diff)
downloadrtems-69537ca9eccfa12142dea588fa34b70a6d220705.tar.bz2
Patch rtems-rc-20000104-16.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts the libbsp/i386 subdirectory to full automake.
Diffstat (limited to 'c/src/lib/libbsp/i386/pc386/include/Makefile.am')
-rw-r--r--c/src/lib/libbsp/i386/pc386/include/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/include/Makefile.am b/c/src/lib/libbsp/i386/pc386/include/Makefile.am
new file mode 100644
index 0000000000..e17a9968b1
--- /dev/null
+++ b/c/src/lib/libbsp/i386/pc386/include/Makefile.am
@@ -0,0 +1,31 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+# This driver needs to be reworked for the BSD stack.
+# We only install wd80x3.h if HAS_NETWORKING was defined
+if HAS_NETWORKING
+WD80X3 = wd80x3.h
+endif
+
+H_FILES = bsp.h crt.h $(WD80X3)
+noinst_HEADERS = $(H_FILES)
+
+$(PROJECT_INCLUDE):
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE) \
+$(H_FILES:%.h=$(PROJECT_INCLUDE)/%.h) \
+$(PROJECT_INCLUDE)/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am