summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/configure.ac
diff options
context:
space:
mode:
authorThomas Doerfler <Thomas.Doerfler@embedded-brains.de>2005-09-29 08:05:32 +0000
committerThomas Doerfler <Thomas.Doerfler@embedded-brains.de>2005-09-29 08:05:32 +0000
commitd1572bcf1c92b47f995a482934a3232f83d1f84a (patch)
treede4863a1bd128f2d0c1e4987e9e7bdb8250ae12f /c/src/lib/libbsp/i386/pc386/configure.ac
parent2005-09-25 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-d1572bcf1c92b47f995a482934a3232f83d1f84a.tar.bz2
2005-09-29 Thomas Doerfler <Thomas.Doerfler@imd-systems.de>
PR 649/bsps * ide/idecfg.c, configure.ac: added configuration items for primary/secondary IDE interface
Diffstat (limited to 'c/src/lib/libbsp/i386/pc386/configure.ac')
-rw-r--r--c/src/lib/libbsp/i386/pc386/configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/configure.ac b/c/src/lib/libbsp/i386/pc386/configure.ac
index 09fc611525..5f34c22360 100644
--- a/c/src/lib/libbsp/i386/pc386/configure.ac
+++ b/c/src/lib/libbsp/i386/pc386/configure.ac
@@ -18,6 +18,22 @@ RTEMS_PROG_CCAS
RTEMS_CHECK_NETWORKING
+RTEMS_BSPOPTS_SET([IDE_USE_PRIMARY_INTERFACE],[*],[1])
+RTEMS_BSPOPTS_HELP([IDE_USE_PRIMARY_INTERFACE],
+[Determines, whether RTEMS will try to use the primary IDE interface.
+ Disable it, if:
+ - you have no primary IDE interface
+ - or you have no disk attached to this interface
+ - or you do not want to access disks attached to this interface])
+
+RTEMS_BSPOPTS_SET([IDE_USE_SECONDARY_INTERFACE],[*],[0])
+RTEMS_BSPOPTS_HELP([IDE_USE_SECONDARY_INTERFACE],
+[Determines, whether RTEMS will try to use the primary IDE interface.
+ Enable it, if:
+ - you have a secondary IDE interface
+ - and you have at least one disk attached to this interface
+ - and you do want to access disks attached to this interface])
+
## if this is an i386, does gas have good code16 support?
RTEMS_I386_GAS_CODE16
AM_CONDITIONAL(RTEMS_GAS_CODE16,[test "$RTEMS_GAS_CODE16" = "yes"])