summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2014-12-11 15:16:34 -0600
committerJoel Sherrill <joel.sherrill@oarcorp.com>2015-01-04 13:44:56 -0600
commit93546b879f173a07f95133a7ebfcf2865dc398b7 (patch)
treea87552030a5226cfeb075b56d38ec86dba2e7749 /c/src/lib/libbsp/i386/pc386/configure.ac
parentpc386: Add BSP_ENABLE_VGA BSP option (diff)
downloadrtems-93546b879f173a07f95133a7ebfcf2865dc398b7.tar.bz2
pc386: Add BSP_ENABLE_IDE BSP option
This allows the IDE support to be completely disabled. It is needed to prevent hangs on some hardware. In particular, the Intel Edison where it is not present.
Diffstat (limited to 'c/src/lib/libbsp/i386/pc386/configure.ac')
-rw-r--r--c/src/lib/libbsp/i386/pc386/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/configure.ac b/c/src/lib/libbsp/i386/pc386/configure.ac
index bdedb0c52f..96812c8b70 100644
--- a/c/src/lib/libbsp/i386/pc386/configure.ac
+++ b/c/src/lib/libbsp/i386/pc386/configure.ac
@@ -22,6 +22,11 @@ RTEMS_BSPOPTS_HELP([BSP_ENABLE_VGA],
[Set if the VGA and keyboard console support is enabled.])
AM_CONDITIONAL(RTEMS_VGA,[test "$BSP_ENABLE_VGA" = "1"])
+RTEMS_BSPOPTS_SET([BSP_ENABLE_IDE],[*],[1])
+RTEMS_BSPOPTS_HELP([BSP_ENABLE_IDE],
+[Set if IDE support is enabled.])
+AM_CONDITIONAL(HAS_IDE,[test "$BSP_ENABLE_IDE" = "1"])
+
RTEMS_BSPOPTS_SET([USE_COM1_AS_CONSOLE],[*],[0])
RTEMS_BSPOPTS_HELP([USE_COM1_AS_CONSOLE],
[Determines, whether the console will be associated with the standard