summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel@rtems.org>2017-12-18 13:54:08 -0600
committerJoel Sherrill <joel@rtems.org>2017-12-19 11:06:36 -0600
commitd386bce90d4bb8249aa2f1a4ab5078b171c6c957 (patch)
treeb645ec27e592b3cdeb299c485b9f040cc6d79585 /c/src/lib/libbsp/i386/pc386/Makefile.am
parentepiphany: Simplify bsp_specs (diff)
downloadrtems-d386bce90d4bb8249aa2f1a4ab5078b171c6c957.tar.bz2
pc386: Simplify bsp_specs
If this has any issues, check that the change in linking the 16-bit startup code in Makefile.am generates the same code. This was odd code and didn't need the RTEMS linkcmds anyway. Updates #3520.
Diffstat (limited to 'c/src/lib/libbsp/i386/pc386/Makefile.am')
-rw-r--r--c/src/lib/libbsp/i386/pc386/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/Makefile.am b/c/src/lib/libbsp/i386/pc386/Makefile.am
index fa15c06e3e..e30411e4cc 100644
--- a/c/src/lib/libbsp/i386/pc386/Makefile.am
+++ b/c/src/lib/libbsp/i386/pc386/Makefile.am
@@ -52,7 +52,7 @@ start16.$(OBJEXT): start/start16.S
$(CPPASCOMPILE) $(AM_CPPFLAGS) -DHEADERADDR=$(HEADERADDR) -o $@ -c $<
start16-elf32.$(OBJEXT): start16.$(OBJEXT)
- $(LD) -N -T $(top_srcdir)/startup/linkcmds -Ttext $(START16ADDR) -e start16 -nostdlib \
+ $(LD) -N -Ttext $(START16ADDR) -e start16 -nostdlib \
--oformat=elf32-i386 \
-o $@ $<