summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-07 12:26:57 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-07 12:26:57 +0000
commitb3c7b2d808a670c856879711fb7b08394b4dab28 (patch)
tree37864048057f93f3412c4f4d22a1d9e3b2c60247 /c/src/lib/libbsp/i386/pc386/Makefile.am
parent2004-01-07 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-b3c7b2d808a670c856879711fb7b08394b4dab28.tar.bz2
2004-01-07 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* start/Makefile.am: Remove. * Makefile.am: Merge-in start/Makefile.am. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/i386/pc386/Makefile.am')
-rw-r--r--c/src/lib/libbsp/i386/pc386/Makefile.am41
1 files changed, 37 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/Makefile.am b/c/src/lib/libbsp/i386/pc386/Makefile.am
index 645059cc89..86b1149ac3 100644
--- a/c/src/lib/libbsp/i386/pc386/Makefile.am
+++ b/c/src/lib/libbsp/i386/pc386/Makefile.am
@@ -4,13 +4,16 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
+# FIXME: We must not include *.cfg
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../bsp.am
+
# wrapup is the one that actually builds and installs the library
# from the individual .rel files built in other directories
-SUBDIRS = . tools start startup clock console timer ne2000 wd8003 3c509 ide \
+SUBDIRS = . tools startup clock console timer ne2000 wd8003 3c509 ide \
wrapup
-include $(top_srcdir)/../../bsp.am
-
# This driver needs to be reworked for the BSD stack.
# We only install wd80x3.h if HAS_NETWORKING was defined
if HAS_NETWORKING
@@ -20,10 +23,32 @@ endif
include_HEADERS += include/crt.h
nodist_include_HEADERS += $(top_srcdir)/../../shared/include/coverhd.h
-all-local: $(PREINSTALL_FILES)
+S_FILES = start/start.S
+$(ARCH)/%$(LIB_VARIANT).$(OBJEXT): start/start.S $(ARCH)/$(dirstamp)
+ ${CCASCOMPILE} -DASM -o $@ -c $<
+
+project_lib_DATA = $(ARCH)/start$(LIB_VARIANT).$(OBJEXT)
+
+S_FILES += start/start16.S
+$(ARCH)/start16.$(OBJEXT): start/start16.S $(ARCH)/$(dirstamp)
+ $(COMPILE.S) $(AM_CPPFLAGS) -DHEADERADDR=$(HEADERADDR) -o $@ $<
+
+$(ARCH)/start16$(LIB_VARIANT)-elf32.$(OBJEXT): $(ARCH)/start16.$(OBJEXT) $(ARCH)/$(dirstamp)
+ $(LD) -N -T $(top_srcdir)/startup/linkcmds -Ttext $(START16ADDR) -e start16 -nostdlib \
+ --oformat=elf32-i386 \
+ -o $@ $<
+
+$(ARCH)/start16$(LIB_VARIANT).bin: $(ARCH)/start16$(LIB_VARIANT)-elf32.$(OBJEXT)
+ $(OBJCOPY) -O binary $< $@
+
+project_lib_DATA += $(ARCH)/start16$(LIB_VARIANT).bin
+
+all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
EXTRA_DIST = HOWTO README.dec21140 STATUS times_i486dx times_p5
+TMPINSTALL_FILES =
+
if HAS_NETWORKING
$(PROJECT_INCLUDE)/wd80x3.h: include/wd80x3.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/wd80x3.h
@@ -38,5 +63,13 @@ $(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h $(PRO
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/coverhd.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
+$(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT): $(ARCH)/start$(LIB_VARIANT).$(OBJEXT) $(PROJECT_LIB)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+TMPINSTALL_FILES += $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+
+$(PROJECT_LIB)/start16$(LIB_VARIANT).bin: $(ARCH)/start16$(LIB_VARIANT).bin $(PROJECT_LIB)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/start16$(LIB_VARIANT).bin
+TMPINSTALL_FILES += $(PROJECT_LIB)/start16$(LIB_VARIANT).bin
+
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am