summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2016-05-06 17:55:29 +1000
committerChris Johns <chrisj@rtems.org>2016-05-11 11:45:01 +1000
commit93fb8797961f602ea70ac5b846a066b05db44b18 (patch)
tree5f0fa3a6427b178a0763ec8c6255895133e75214 /c/src/lib/libbsp/i386/Makefile.am
parenti386/pc386: Fix printk with the console changes. (diff)
downloadrtems-93fb8797961f602ea70ac5b846a066b05db44b18.tar.bz2
i386/pc386: Fix interrupt support.
Fix the interrupt and stop the spurious interrupt from happening. The fix moves the EOI to C code and cleans that functionality out of the asm part of the ISR handler. The code checks the ISR and IRR registers on the enable. Only ack the master for a slave IRQ if the slave has no other pending requests.
Diffstat (limited to 'c/src/lib/libbsp/i386/Makefile.am')
-rw-r--r--c/src/lib/libbsp/i386/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/i386/Makefile.am b/c/src/lib/libbsp/i386/Makefile.am
index 3b6df65b1d..567f75fdbd 100644
--- a/c/src/lib/libbsp/i386/Makefile.am
+++ b/c/src/lib/libbsp/i386/Makefile.am
@@ -19,6 +19,7 @@ EXTRA_DIST += shared/irq/irq.h shared/irq/irq.c
EXTRA_DIST += shared/irq/irq_asm.h shared/irq/irq_asm.S
EXTRA_DIST += shared/irq/idt.c
EXTRA_DIST += shared/irq/irq_init.c
+EXTRA_DIST += shared/irq/elcr.c
# shared/pci
EXTRA_DIST += shared/pci/pcibios.c