summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/h8300/h8sim/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-07-06 20:07:34 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-07-06 20:07:34 +0000
commit501d312a91f66a56f4958f399d9fe30465a86437 (patch)
tree275d5093b512a8a751efff5f79f0184da243fbd7 /c/src/lib/libbsp/h8300/h8sim/include/Makefile.am
parentAdded missing #endif's. (diff)
downloadrtems-501d312a91f66a56f4958f399d9fe30465a86437.tar.bz2
Added baseline for h8 simulator BSP to support the simulator in gdb 5.0
Diffstat (limited to 'c/src/lib/libbsp/h8300/h8sim/include/Makefile.am')
-rw-r--r--c/src/lib/libbsp/h8300/h8sim/include/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/h8300/h8sim/include/Makefile.am b/c/src/lib/libbsp/h8300/h8sim/include/Makefile.am
new file mode 100644
index 0000000000..1d6c3074ec
--- /dev/null
+++ b/c/src/lib/libbsp/h8300/h8sim/include/Makefile.am
@@ -0,0 +1,25 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = bsp.h ../../../shared/include/coverhd.h
+
+$(PROJECT_INCLUDE):
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/bsp.h: bsp.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/coverhd.h: ../../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/bsp.h \
+ $(PROJECT_INCLUDE)/coverhd.h
+
+all-local: $(TMPINSTALL_FILES)
+
+EXTRA_DIST = bsp.h
+
+include $(top_srcdir)/../../../../../../automake/local.am