summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/h8300/h8sim/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 10:26:06 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 10:26:06 +0000
commit8d7f47f4a5f1a7cd87bcd1a10f95b544d7b380a8 (patch)
tree27452a6ba2972d4e2d87bac90cf8ad1ddc02db4b /c/src/lib/libbsp/h8300/h8sim/Makefile.am
parent2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-8d7f47f4a5f1a7cd87bcd1a10f95b544d7b380a8.tar.bz2
2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. Reflect changes to bsp.am. * include/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/h8300/h8sim/Makefile.am')
-rw-r--r--c/src/lib/libbsp/h8300/h8sim/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/h8300/h8sim/Makefile.am b/c/src/lib/libbsp/h8300/h8sim/Makefile.am
index b507a3af3d..e707e1ff56 100644
--- a/c/src/lib/libbsp/h8300/h8sim/Makefile.am
+++ b/c/src/lib/libbsp/h8300/h8sim/Makefile.am
@@ -5,13 +5,21 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-#SUBDIRS = include start startup clock console timer wrapup
-SUBDIRS = include start startup clock console wrapup
+# from the individual .rel files built in other directories
+#SUBDIRS = . start startup clock console timer wrapup
+SUBDIRS = . start startup clock console wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs times
+nodist_include_HEADERS += $(top_srcdir)/../../shared/include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = times
+
+$(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am