summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/epiphany/epiphany_sim/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2020-07-03 07:46:24 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2020-07-05 18:05:25 +0200
commit401b237f9349362b40e3c08f7fd8db38fc51c5d4 (patch)
tree39802344a64c2f9febe86b01bc21b8459567f276 /c/src/lib/libbsp/epiphany/epiphany_sim/Makefile.am
parentbsps/powerpc: Remove obsolete BSPs (diff)
downloadrtems-401b237f9349362b40e3c08f7fd8db38fc51c5d4.tar.bz2
epiphany: Remove support for this target
Due to an unmaintained toolchain (internal errors in GCC, no FSF GDB integration) the Epiphany architecture was obsoleted in RTEMS 5.1. Update #3941.
Diffstat (limited to 'c/src/lib/libbsp/epiphany/epiphany_sim/Makefile.am')
-rw-r--r--c/src/lib/libbsp/epiphany/epiphany_sim/Makefile.am66
1 files changed, 0 insertions, 66 deletions
diff --git a/c/src/lib/libbsp/epiphany/epiphany_sim/Makefile.am b/c/src/lib/libbsp/epiphany/epiphany_sim/Makefile.am
deleted file mode 100644
index f4901fd764..0000000000
--- a/c/src/lib/libbsp/epiphany/epiphany_sim/Makefile.am
+++ /dev/null
@@ -1,66 +0,0 @@
-##
-#
-# @brief Makefile of LibBSP for the Epiphany simulator.
-#
-#
-ACLOCAL_AMFLAGS = -I ../../../../aclocal
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../bsp.am
-
-dist_project_lib_DATA = ../../../../../../bsps/epiphany/epiphany_sim/start/bsp_specs
-
-###############################################################################
-# Header #
-###############################################################################
-
-###############################################################################
-# Data #
-###############################################################################
-
-start.$(OBJEXT): ../../../../../../bsps/epiphany/epiphany_sim/start/start.S
- $(CPPASCOMPILE) -o $@ -c $<
-project_lib_DATA = start.$(OBJEXT)
-
-project_lib_DATA += linkcmds
-
-###############################################################################
-# LibBSP #
-###############################################################################
-
-project_lib_LIBRARIES = librtemsbsp.a
-
-# Startup
-librtemsbsp_a_SOURCES = ../../../../../../bsps/shared/start/bspreset-empty.c
-librtemsbsp_a_SOURCES += ../../../../../../bsps/shared/start/bspstart-empty.c
-
-# Shared
-librtemsbsp_a_SOURCES += ../../../../../../bsps/shared/dev/getentropy/getentropy-cpucounter.c
-librtemsbsp_a_SOURCES += ../../../../../../bsps/shared/start/bspfatal-default.c
-librtemsbsp_a_SOURCES += ../../../../../../bsps/shared/start/sbrk.c
-librtemsbsp_a_SOURCES += ../../../../../../bsps/shared/start/stackalloc.c
-librtemsbsp_a_SOURCES += ../../../../../../bsps/shared/start/bspgetworkarea-default.c
-
-# clock
-librtemsbsp_a_SOURCES += ../../../../../../bsps/shared/dev/clock/clock-simidle.c
-
-# Timer
-librtemsbsp_a_SOURCES += ../../../../../../bsps/epiphany/epiphany_sim/btimer/btimer.c
-
-# console
-librtemsbsp_a_SOURCES += ../../../../../../bsps/shared/dev/serial/console-polled.c
-
-# IRQ
-librtemsbsp_a_SOURCES += ../../../../../../bsps/shared/irq/irq-default-handler.c
-librtemsbsp_a_SOURCES += ../../../../../../bsps/epiphany/epiphany_sim/irq/irq.c
-
-# Cache
-librtemsbsp_a_SOURCES += ../../../../../../bsps/shared/cache/nocache.c
-
-# debugio
-librtemsbsp_a_SOURCES += ../../../../../../bsps/epiphany/epiphany_sim/console/console-io.c
-
-
-include $(srcdir)/../../../../../../bsps/shared/irq-sources.am
-include $(srcdir)/../../../../../../bsps/shared/shared-sources.am
-include $(srcdir)/../../../../../../bsps/epiphany/epiphany_sim/headers.am