summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-16 13:00:42 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-16 13:00:42 +0000
commit994202a41792070b06809c614ae7ea73f1d79b84 (patch)
treeec0e15541054a93902afe12dc0f294cfad5508dd /c/src/lib/libbsp/configure.in
parentModified to pick up components from libcpu. (diff)
downloadrtems-994202a41792070b06809c614ae7ea73f1d79b84.tar.bz2
Patch rtems-rc-20000615-4-cvs.diff from Ralf Corsepius
<corsepiu@faw.uni-ulm.de> to fix the following: * lib/configure.in actually is libc's configure.in, so let it depend on libc not on lib [In my Cygnus/GNU configuration scheme, lib/include and lib/libc are treated as one unit, while libcpu and libbsp are treated as separate units.] * Allow empty --enable-bare* flags for the bare bsp. The formerly used scheme is too strict for our multilib experiments.
Diffstat (limited to 'c/src/lib/libbsp/configure.in')
-rw-r--r--c/src/lib/libbsp/configure.in17
1 files changed, 1 insertions, 16 deletions
diff --git a/c/src/lib/libbsp/configure.in b/c/src/lib/libbsp/configure.in
index 70cbabb8d3..75f642004f 100644
--- a/c/src/lib/libbsp/configure.in
+++ b/c/src/lib/libbsp/configure.in
@@ -28,22 +28,7 @@ RTEMS_BSP_ALIAS(${RTEMS_BSP},bspdir)
# Is there code where there should be for this BSP?
# The bare bsp is a special case as it is not under the RTEMS_CPU path
-case $bspdir in
- bare)
- bspcpudir=
- if test "X${BARE_CPU_CFLAGS}" = "X" ; then
- AC_MSG_ERROR([--enable-bare-cpu-cflags not specified for bare bsp])
- fi
- if test "X${BARE_CPU_MODEL}" = "X" ; then
- AC_MSG_ERROR([--enable-bare-cpu-model not specified for bare bsp])
- fi
- ;;
- *)
- bspcpudir=$RTEMS_CPU/
- ;;
-esac
-
-if test "$RTEMS_BSP" = "bare" ; then
+if test "$bspdir" = "bare" ; then
RTEMS_LIBBSP_CPU_SUBDIR="bare"
else
RTEMS_LIBBSP_CPU_SUBDIR=$RTEMS_CPU