summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/c4x/c4xsim/start/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-09 15:04:10 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-09 15:04:10 +0000
commitcf34106f4b9044e25d6e4ce844cfc9ec9b407001 (patch)
treeee6aec45edf73a271d400df8eacb24a765c9a019 /c/src/lib/libbsp/c4x/c4xsim/start/Makefile.am
parent2003-12-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-cf34106f4b9044e25d6e4ce844cfc9ec9b407001.tar.bz2
2003-12-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* start/Makefile.am: Misc cleanups and fixes. * startup/Makefile.am: Misc cleanups and fixes. * wrapup/Makefile.am: Misc cleanups and fixes.
Diffstat (limited to 'c/src/lib/libbsp/c4x/c4xsim/start/Makefile.am')
-rw-r--r--c/src/lib/libbsp/c4x/c4xsim/start/Makefile.am18
1 files changed, 7 insertions, 11 deletions
diff --git a/c/src/lib/libbsp/c4x/c4xsim/start/Makefile.am b/c/src/lib/libbsp/c4x/c4xsim/start/Makefile.am
index 9641f42059..62fae6f2fe 100644
--- a/c/src/lib/libbsp/c4x/c4xsim/start/Makefile.am
+++ b/c/src/lib/libbsp/c4x/c4xsim/start/Makefile.am
@@ -9,24 +9,20 @@ OBJS = $(S_O_FILES)
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../../../automake/lib.am
+include $(top_srcdir)/../../bspstart.am
#
# (OPTIONAL) Add local stuff here using +=
#
-install-data-local: $(PROJECT_RELEASE)/lib/start$(LIB_VARIANT).$(OBJEXT)
- @$(mkinstalldirs) $(DESTDIR)$(bsplibdir)
- $(INSTALL_DATA) $< $(DESTDIR)$(bsplibdir)
+project_lib_DATA = $(ARCH)/start$(LIB_VARIANT).$(OBJEXT)
-$(PROJECT_RELEASE)/lib/start$(LIB_VARIANT).$(OBJEXT): $(ARCH)/start.$(OBJEXT)
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/start$(LIB_VARIANT).$(OBJEXT)
-
-all-local: $(OBJS) $(ARCH)/start.$(OBJEXT) $(TMPINSTALL_FILES)
-
-.PRECIOUS: $(ARCH)/start.$(OBJEXT)
+all-local: $(TMPINSTALL_FILES)
EXTRA_DIST = start.S
+${PROJECT_RELEASE}/lib/start$(LIB_VARIANT).$(OBJEXT): $(ARCH)/start$(LIB_VARIANT).$(OBJEXT) ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/start$(LIB_VARIANT).$(OBJEXT)
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/start$(LIB_VARIANT).$(OBJEXT)
+
include $(top_srcdir)/../../../../automake/local.am