summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/bare/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 13:56:35 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 13:56:35 +0000
commit94608578a2c5d90d87ca729bb5d45f945679254a (patch)
tree140f91ec5f522c2c11a18350b6868535a7a97e67 /c/src/lib/libbsp/bare/include/Makefile.am
parentPatch from Eric Valette <valette@crf.canon.fr> that makes sure the (diff)
downloadrtems-94608578a2c5d90d87ca729bb5d45f945679254a.tar.bz2
Patch rtems-rc-20000104-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts nearly all of libbsp/sh to automake. Comments follow: 1. Almost full automake support for the libbsp/sh/ subdirectories (exception libbsp/sh/gensh*/wrapup/*) 2. Fixes for libbsp/bare/* 3. Updates to libbsp/* configuration which supports old (autoconf/deep configuration) and new (automake/flat/cascaded configuration) style configuration of libbsp/<cpu>/*
Diffstat (limited to 'c/src/lib/libbsp/bare/include/Makefile.am')
-rw-r--r--c/src/lib/libbsp/bare/include/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/bare/include/Makefile.am b/c/src/lib/libbsp/bare/include/Makefile.am
index e5577f4fe6..46ceb70cac 100644
--- a/c/src/lib/libbsp/bare/include/Makefile.am
+++ b/c/src/lib/libbsp/bare/include/Makefile.am
@@ -3,17 +3,20 @@
##
AUTOMAKE_OPTIONS = foreign 1.4
-H_FILES = bsp.h $(srcdir)/../../../shared/coverhd.h
-
+H_FILES = bsp.h
noinst_HEADERS = $(H_FILES)
TMPINSTALL_FILES += \
$(PROJECT_INCLUDE) \
-$(H_FILES:%=$(PROJECT_INCLUDE)/%)
+$(H_FILES:%.h=$(PROJECT_INCLUDE)/%.h) \
+$(PROJECT_INCLUDE)/coverhd.h
$(PROJECT_INCLUDE)/%.h: %.h
$(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/coverhd.h: $(srcdir)/../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+
all-local: $(TMPINSTALL_FILES)
include $(top_srcdir)/../../../../../automake/local.am