summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/avr/avrtest/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-11-20 15:39:04 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-11-20 15:39:04 +0000
commit858ea06c85966d406ad4e2544ee8fe46ed6d2345 (patch)
tree55d220b62693c5abebbe14b7d3edbe5e8845ca44 /c/src/lib/libbsp/avr/avrtest/Makefile.am
parent2008-11-20 Daron Chabot <daronchabot@gmail.com> (diff)
downloadrtems-858ea06c85966d406ad4e2544ee8fe46ed6d2345.tar.bz2
2008-11-20 Joel Sherrill <joel.sherrill@oarcorp.com>
* .cvsignore, ChangeLog, Makefile.am, README, bsp_specs, configure.ac, preinstall.am, console/console-io.c, include/.cvsignore, include/bsp.h, start/start.S, startup/linkcmds, tools/.cvsignore, tools/Makefile.am, tools/configure.ac, tools/runtest.in: New files.
Diffstat (limited to 'c/src/lib/libbsp/avr/avrtest/Makefile.am')
-rw-r--r--c/src/lib/libbsp/avr/avrtest/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/avr/avrtest/Makefile.am b/c/src/lib/libbsp/avr/avrtest/Makefile.am
new file mode 100644
index 0000000000..ad3d4ca55d
--- /dev/null
+++ b/c/src/lib/libbsp/avr/avrtest/Makefile.am
@@ -0,0 +1,49 @@
+##
+## $Id$
+##
+
+ACLOCAL_AMFLAGS = -I ../../../../aclocal
+
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../bsp.am
+
+include_bspdir = $(includedir)/bsp
+
+dist_project_lib_DATA = bsp_specs
+
+include_HEADERS = include/bsp.h
+include_HEADERS += ../../shared/include/tm27.h
+
+nodist_include_HEADERS = include/bspopts.h
+nodist_include_bsp_HEADERS = ../../shared/include/bootcard.h
+DISTCLEANFILES = include/bspopts.h
+noinst_PROGRAMS =
+
+SUBDIRS = . tools
+
+nodist_include_HEADERS += ../../shared/include/coverhd.h
+
+EXTRA_DIST = start/start.S
+start.$(OBJEXT): start/start.S
+ $(CPPASCOMPILE) -o $@ -c $<
+project_lib_DATA = start.$(OBJEXT)
+
+dist_project_lib_DATA += startup/linkcmds
+
+startup_SOURCES = ../../shared/bspclean.c ../../shared/bsplibc.c \
+ ../../shared/bsppredriverhook.c ../../shared/bsppretaskinghook.c \
+ ../../shared/bspgetworkarea.c ../../shared/bsppost.c \
+ ../../shared/bspstart.c ../../shared/bootcard.c ../../shared/sbrk.c \
+ ../../shared/gnatinstallhandler.c
+clock_SOURCES = ../../shared/clock_driver_simidle.c
+console_SOURCES = ../../shared/console-polled.c console/console-io.c
+timer_SOURCES = ../../shared/timerstub.c
+
+noinst_LIBRARIES = libbsp.a
+libbsp_a_SOURCES = $(startup_SOURCES) $(clock_SOURCES) $(console_SOURCES) \
+ $(timer_SOURCES)
+
+EXTRA_DIST += times
+
+include $(srcdir)/preinstall.am
+include $(top_srcdir)/../../../../automake/local.am