summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/vegaplus/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-09-13 13:45:05 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-09-13 13:45:05 +0000
commit456456632d24d9a7ca068d9f8f93f3c50f93e705 (patch)
treeb1bead1e51711bee065a6eb802f5af762059d141 /c/src/lib/libbsp/arm/vegaplus/include/Makefile.am
parent2000-09-13 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-456456632d24d9a7ca068d9f8f93f3c50f93e705.tar.bz2
2000-09-13 Emmanuel Raguet <raguet@crf.canon.fr>
* vegaplus BSP submitted by Emmanuel Raguet <raguet@crf.canon.fr> and Eric Valette <valette@crf.canon.fr>. * vegaplus/bsp_specs, configure.in, console/Makefile.am, include/Makefile.am, include/bsp.h, include/registers.h, irq/Makefile.am, irq/bsp_irq_asm.S, irq/bsp_irq_init.c, irq/irq.c, irq/irq.h, start/Makefile.am, start/start.S, startup/Makefile.am, startup/bspstart.c, startup/exit.c, startup/linkcmds, wrapup/Makefile.am: New files.
Diffstat (limited to 'c/src/lib/libbsp/arm/vegaplus/include/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/vegaplus/include/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/arm/vegaplus/include/Makefile.am b/c/src/lib/libbsp/arm/vegaplus/include/Makefile.am
new file mode 100644
index 0000000000..6e4ee50f82
--- /dev/null
+++ b/c/src/lib/libbsp/arm/vegaplus/include/Makefile.am
@@ -0,0 +1,24 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = bsp.h registers.h
+
+$(PROJECT_INCLUDE):
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE) $(H_FILES:%.h=$(PROJECT_INCLUDE)/%.h)
+
+all: $(PREINSTALL_FILES)
+
+EXTRA_DIST = bspio.h bsp.h uart.h registers.h
+
+include $(top_srcdir)/../../../../../../automake/local.am